请选择 进入手机版 | 继续访问电脑版
查看: 709|回复: 7

macd实用指标

[复制链接]

新浪微博达人勋

五级海风会员

发表于 2017-5-19 10:17 | 显示全部楼层 |阅读模式

马上注册海风会员,享受更多便捷服务!

您需要 登录 才可以下载或查看,没有帐号?注册会员 新浪微博登陆

x
DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))*20,COLORFFFFFF,LINETHICK1;
DEA:EMA(DIFF,9),COLOR00FFFF,LINETHICK1;
MACD:2*(DIFF-DEA), COLORSTICK;
MACD1:2*(DIFF-DEA),COLORRED,LINETHICK0;
MACD2:SMA(MACD1,0,3),COLORFFFF00,LINETHICK0;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLOR00FFFF;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLOR40FF00;
S1:=MACD<0;
S2:= (MACD>=0);
S3:=BARSLAST(CROSS(DIFF,DEA));
S4:=REF(S3,S3+1);
S5:=DEA>REF(DEA,S4);
S6:=DEA;
上成立:=CROSS(DIFF,DEA) AND S5;
下成立:=CROSS(DIFF,DEA) AND S6;
L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
L2:=EMA(L1,9);
L3:=BARSLAST(CROSS(L1,L2));
L4:=REF(L3,L3+1);
L5:=L2;
变盘:CROSS(L1,L2) AND L5,LINETHICK0,COLORD6FF9C;
STICKLINE(变盘,5,-5,4,1),COLORD6FF9C;
成立距今:BARSLAST(CROSS(DIFF,DEA)),LINETHICK0;
L6:=BARSCOUNT(CLOSE);
DRAWTEXT(CROSS(L1,L2),DIFF,'买'),COLOR0000FF;
DRAWTEXT(CROSS(L2,L1),DIFF,'卖'),COLORFFFF00;
REF(DEA,S3),POINTDOT,COLORGREEN;
IF(L1>L2,REF(DEA,S3),0),POINTDOT,LINETHICK5,COLORB078FF;
IF(MACD<0,REF(DEA,S3),0),POINTDOT,LINETHICK5,COLORGREEN;
LS:=IF(DIFF>DEA AND DIFF>0,1,0);
加速上扬:IF(REF(LS=0,1) AND LS=1,0.1,0);
XG1:CROSS(MACD1,MACD2) AND MACD1<0,LINETHICK0;
XG2:CROSS(DIFF,DEA),LINETHICK0;
M1:=MACD>REF(MACD,1) AND DIFF<DEA;
绿柱短了:M1 AND COUNT(M1,10)=1 AND C>MA(C,55) AND COUNT(MACD<0,5)>=5,LINETHICK0;
DRAWTEXT(绿柱短了,MACD,'绿柱短了'),COLOR00FF80;
此为本站的广告赞助商,该站的任何商业行为,与本站无关!
回复

使用道具 举报

新浪微博达人勋

五级海风会员

 楼主| 发表于 2017-5-19 14:35 | 显示全部楼层
AA:=HHV(C,N);
BB:=LLV(C,N);
0,POINTDOT;
DD:C-AA,COLORF00FF0;
KK:  BB-C,COLORGREEN;
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

 楼主| 发表于 2017-5-20 21:23 | 显示全部楼层
AA:=HHV(C,N);
BB:=LLV(C,N);
0,POINTDOT;
DD:C-AA,COLORF00FF0;
KK:BB-C,COLORGREEN;

AA1:=HHV(C,N1);
BB1:=LLV(C,N1);
DD1:C-AA1,COLORF00FF0;
KK1: BB1-C,COLORGREEN;
AA2:=HHV(C,N2);
BB2:=LLV(C,N2);
DD2:C-AA2,COLORF00FF0;
KK2: BB2-C,COLORGREEN;
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

 楼主| 发表于 2017-5-20 21:37 | 显示全部楼层
AA:=HHV(C,N);
BB:=LLV(C,N);
0,POINTDOT;
DD:C-AA,COLORF00FF0;
KK:BB-C,COLORGREEN;

AA1:=HHV(C,N1);
BB1:=LLV(C,N1);
DD1:C-AA1,COLORF00FF0;
KK1: BB1-C,COLORGREEN;
AA2:=HHV(C,N2);
BB2:=LLV(C,N2);
DD2:C-AA2,COLORF00FF0;
KK2: BB2-C,COLORGREEN;
AA3:=HHV(C,N3);
BB3:=LLV(C,N3);
DD3:C-AA3,COLORF00FF0;
KK3: BB3-C,COLORGREEN;
AA4:=HHV(C,N4);
BB4:=LLV(C,N4);
DD4:C-AA4,COLORF00FF0;
KK4: BB4-C,COLORGREEN;
AA5:=HHV(C,N5);
BB5:=LLV(C,N5);
DD5:C-AA5,COLORF00FF0;
KK5: BB5-C,COLORGREEN;
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

 楼主| 发表于 2017-5-20 23:15 | 显示全部楼层
VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));  
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));  
买卖差:=(买盘 + 卖盘);
T4:=100*(C-LLV(L,N))/(HHV(H,N)-LLV(L,N)),COLOR55FFFF,LINETHICK2;
K:=MA(C,5);
D:=MA(C,20);
JX1:=BARSSINCE(买盘);  
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);  
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);  
VAR30:=MA(VOL,JY2);
神比:=(买盘 / VAR30);  
鬼比:=(卖盘 / VAR30);  
VAR2:=(HIGH - LOW);  
VAR3:=ABS((OPEN - CLOSE));  
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));  
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);  
VAR6:=((VAR3 / VAR2) * VOL);  
VAR7:=((VAR4 / VAR2) * VOL);  
VAR8:=((VAR5 / VAR2) * VOL);  
STICKLINE(K<D,0,VOL,5,0),COLOREEDD11;
STICKLINE(K>=D ,0,VOL,5,1),COLOR0000FF;
STICKLINE(( 买卖差 < 0),0,买卖差,4,0),COLOREEDD11;
STICKLINE((((买卖差 > 0 AND K>=D AND  C>=MA(C,5) AND VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),0,VAR6,4,0),COLOR00FFFF;
STICKLINE( 买卖差 > 0  AND K>=D AND  C>=MA(C,5),买盘,0,2,0),COLOR0000FF;
  买卖:1*买卖差/10000,COLORFF00FF;
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

 楼主| 发表于 2017-5-21 11:34 | 显示全部楼层
EMA13:MA(C,13),COLORWHITE,LINETHICK2;
EMA34:MA(C,34),COLORYELLOW;
EMA55:MA(C,55),COLORFF00FF;

{见好就收}
Y:=(EMA13-EMA55)/EMA13*100;
JHJX:=REF(Y,1)<=10 AND Y>10;
{DRAWICON(JHJX,H,1);}
DRAWTEXT(JHJX,H,'见好就收'),COLORF00FF0;
{红杏出墙}
HX1:=EMA13<EMA34 AND EMA34<EMA55;{股价长期下跌,并且远离长期均线}
HX2:=BARSLAST((C-EMA13)/EMA13*100<-6);{收盘价在13均线%6到现在的天数}
HX3:=ABS(1-EMA55/REF(C,1))>0.1;
HX6:=BARSLAST(CROSS(EMA55,EMA34))>=20;{13日均线下降趋于走平}
HX4:=ABS(1-REF(EMA13,1)/EMA13)<0.004 AND C<EMA34;
HX5:=REF(C,1)<EMA13 AND C>EMA13 AND C>O;
HX7:=HX1 {AND HX3} AND HX4 AND HX5 ;
HX8:=HX7 AND FILTER(HX7,10);{满足后10天内不标记}
DRAWTEXT(HX8,L-0.05,'红杏出墙'),COLORYELLOW;
{黑客点击}
DJ1:=EMA13>EMA34 AND EMA34<EMA55;{13日均线大于34日均线,34日均线小于55日均线}
DJ2:=O>EMA55;{开盘价大于55日均线}
DJ3:=CROSS(EMA13,EMA55) OR ABS(1-EMA13/EMA55)<0.002;
DJ4:=O>C AND C<REF(C,1);
HKDJ:= DJ2 AND DJ3 AND DJ4;
DRAWTEXT(HKDJ AND FILTER(HKDJ,10),L-0.03,'黑客点击'),COLORD6BA63;


{红衣侠女}
XN1:=ABS(1-HHV(EMA55,5)/LLV(EMA55,5))<0.02;
XN2:=CROSS(EMA13,EMA55) OR ABS(1-EMA13/EMA55)<0.002;
XN3:=C>O AND V>REF(V,1) AND C>EMA55;
HYXN:=XN1 AND XN2 AND XN3;
DRAWTEXT(HYXN AND FILTER(HYXN,5),L-0.05,'红衣侠女'),COLORF00FF0;

{海底捞月}
LY1:=COUNT(ABS(1-EMA55/EMA34)<0.1,20)>=16;
LY2:=COUNT(CROSS(EMA34,EMA13),40)>=1 AND COUNT(CROSS(EMA55,EMA13),40)>=1;
LY3:=CROSS(EMA13,EMA55);
HDLY:=LY1 AND LY2 AND LY3;
DRAWTEXT(HDLY AND FILTER(HDLY,5),L-0.25,'海底捞月'),COLORGREEN;

{均线互换}
JXHH:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55);
DRAWTEXT(JXHH,L+0.09,'均线互换'),COLOR0099FF;
{梅开二度}
MKED1:=BARSLAST(REF(CROSS(EMA34,EMA13),1));
MKED2:=COUNT(H>=EMA55,MKED1)=MKED1;
MKED:=MKED2 AND CROSS(EMA13,EMA34);
DRAWTEXT(MKED,L-0.1,'梅开二度'),COLOR0044FF;
{一阳三线}
YY1:=C>EMA13 AND O<EMA13;
YY2:=C>EMA34 AND O<EMA34;
YY3:=C>EMA55 AND O<EMA55;
YYSX:=YY1 AND YY2 AND YY3;
DRAWTEXT(YYSX,H+0.1,'一阳三线'),COLORRED;

{揭竿而起}
MAX3:=MAX(MAX(EMA13,EMA34),EMA55);
MIN3:=MIN(MIN(EMA13,EMA34),EMA55);
JG1:=ABS(EMA13-EMA34)<C*0.05;{13线34线55线接近}
JG2:=ABS(EMA34-EMA55)<C*0.05;
JG3:=C>=O*1.03 AND C>MAX3;{阳线3%}
JG4:=O>MIN3 AND O<MAX3;
JG5:=C>REF(H,5);
JG6:=(C-EMA34)/EMA34<=0.15;{控制价高}
JG7:=V>MA(V,5) AND MA(V,10);
JGEQ:=JG1 AND JG2 AND JG3 AND JG4 AND JG5 AND JG6 AND JG7;
DRAWTEXT(JGEQ,H+0.1,'揭竿而起'),COLORGREEN;


{浪子回头}
LZ1:=REF(C,2)<REF(O,2) AND REF(C,1)<REF(O,1) AND C<O;
LZ2:=C<=REF(C,1) AND REF(C,1)<=REF(C,2);
LZ3:=MA(V,3)<REF(V,3);
LZ4:=REF(C,3)>EMA13 AND (C>EMA55 OR ABS(1-C/EMA55)<0.01);
LZHT:=LZ1 AND LZ2 AND LZ3 AND LZ4;
DRAWTEXT(LZHT AND FILTER(LZHT,5),L-0.1,'浪子回头'),COLOR00FF99;

{走四方}
ZSF1:=REF(C,4)>REF(O,4) AND (REF(C,4)>EMA13 OR REF(C,4)>EMA34) AND (ABS(1-REF(EMA55,4)/EMA55)<0.01 OR MA(EMA55,4)>REF(EMA55,5));
ZSF2:=COUNT(ABS((1-REF(C,1)/C)*100)<3,4)=4 AND MA(V,4)<REF(V,4)*0.8;
ZSF:=ZSF1 AND ZSF2;
DRAWTEXT(ZSF AND FILTER(ZSF,4),L-0.1,'走四方'),COLORBLUE;

{一枝独秀}
YZ1:=C/O>1.01 AND H/C>1.025 ;{收阳有上影}
YZ2:=EMA13>MAX(EMA34,EMA55) AND C>1.05*EMA13 AND O>MA(C,11);{昨收阳 今大于均线}
YZDX:=YZ1 AND YZ2;
DRAWTEXT(YZDX,(H+C)/2,'一枝独秀'),COLORF00FF0;

{独上高楼}
DSGL1:=REF(C,1)>=REF(O,1);
DSGL2:=O/REF(C,1)>1.029 AND O/C>1.03 AND O/MAX(EMA13,EMA55)>1.03;
DSGL:=DSGL1 AND DSGL2;
DRAWTEXT(DSGL,(O+C)/2,'独上高楼'),COLORF00FF0;

{金屋藏娇}
JWCJ1:=C<O AND REF(C,1)<REF(O,1);
JWCJ2:=O<=REF(C,1) AND L>=REF(L,1);
JWCJ3:=REF(C,1)/REF(L,1)>1.02;
JWCJ4:=EMA13<EMA34 OR EMA13<EMA55;
JWCJ:=JWCJ1 AND JWCJ2 AND JWCJ3 AND JWCJ4;
DRAWTEXT(JWCJ,LOW-0.2,'金屋藏娇'),COLORYELLOW;

{日月合璧}
RYHB1:=REF(O,1)<=REF(C,2) AND REF(C,1)<REF(O,1) AND ABS(1-REF(C,1)/REF(L,1))<0.02;
RYHB2:=C>O AND ABS(1-C/REF(O,1))<0.025 AND ABS(1-O/REF(C,1))<0.025;
RYHB3:=EMA13<REF(EMA13,1) OR ABS(1-EMA13/REF(EMA13,1))<0.01 AND (EMA13<EMA34 OR EMA13<EMA55);
RYHB4:=REF(L,1)<=LLV(REF(L,1),10);
RYHB:=RYHB1 AND RYHB2 AND RYHB3 AND RYHB4;
DRAWTEXT(RYHB ,LOW,'日月合璧'),COLORYELLOW;
{投石问路}
TSWL1:=CROSS(EMA13,EMA34) AND EMA13<EMA55;
DRAWTEXT(TSWL1,L-0.1,'投石问路'),COLOR0044FF;
{分道扬镳}
FDYB:=CROSS(EMA34,EMA13) AND EMA34>EMA55;
DRAWTEXT(FDYB,L-0.1,'分道扬镳'),COLOR0044FF;
{三军集结}
SJJJ3:=REF(EMA55,1)>REF(EMA13,1);
SJJJ4:=ABS(1-(MAX(MAX(EMA34,EMA55),EMA13)/MIN(MIN(EMA13,EMA34),EMA55)))<0.005;
SJJJ:=SJJJ3 AND SJJJ4;
DRAWTEXT(SJJJ AND FILTER(SJJJ,5),L-0.1,'三军集结'),COLOR0044FF;
{突出重围}
TCCW1:=REF(EMA55,1)<REF(EMA13,1);
TCCW2:=EMA13<LLV(REF(EMA13,1),5) AND ABS(1-(MAX(MAX(EMA34,EMA55),EMA13)/MIN(MIN(EMA13,EMA34),EMA55)))<0.008;
TCCW:=TCCW1 AND TCCW2;
DRAWTEXT(TCCW AND FILTER(TCCW,5),H+0.01,'突出重围'),COLORF00FF0;
{明修栈道}
MXZD1:=C/O>1.07;
MXZD2:=EMA13>HHV(REF(EMA13,1),5) AND V>HHV(REF(V,1),10) AND V/MA(REF(V,1),5)>2;
MXZD:=MXZD1 AND MXZD2;
DRAWTEXT(MXZD,H+0.01,'明修栈道'),COLORF00FF0;
{暗度陈仓}
ADCC1:=O/C>1.05 AND EMA13/EMA55<1.1 AND EMA13>MA(EMA13,5);
ADCC2:=O/REF(C,1)<1.03;{V<HHV(REF(V,1),5) AND V/MA(REF(V,1),5)<2};
ADCC:=ADCC1 AND ADCC2;
DRAWTEXT(ADCC,(C+O)/2,'暗度陈仓'),COLOR00C5FF;
{破镜重圆}
PJCY1:=REF(O,1)/REF(C,1)>1.02;
PJCY2:=O<=REF(C,1) AND C>=REF(O,1);
PJCY3:=(ABS(1-REF(C,1)/EMA55)<0.05 OR ABS(1-C/EMA55)<0.05 OR ABS(1-MA(C,2)/EMA55)<0.05);
PJCY4:=EMA13>EMA55 OR EMA13>MA(EMA13,5);
PJCY:=PJCY1 AND PJCY2 AND PJCY3 AND PJCY4;
DRAWTEXT(PJCY,LOW,'破镜重圆'),COLORYELLOW;
{一石二鸟}
YSEN1:=REF(C,2)>REF(O,2) AND REF(C,1)<REF(O,1) AND C<O;
YSEN2:=REF(C,2)>EMA55 AND EMA13>EMA55 AND EMA13>=MA(EMA13,5);
YSEN3:=REF(V,2)>REF(V,1) AND REF(V,2)>V;
YSEN:=YSEN1 AND YSEN2 AND YSEN3;
DRAWTEXT(YSEN,H+0.01,'一石二鸟'),COLORBLUE;
{拖泥带水}
TNDS1:=O/REF(C,1)>1.05 AND MIN(C,O)/L>1.03;
TNDS2:=C/MAX(EMA13,EMA55)>1.03 AND C>REF(C,1);
TNDS:=TNDS1 AND TNDS2;
DRAWTEXT(TNDS,(O+C)/2,'拖泥带水'),COLORF00FF0;
{金蝉脱壳}
JCTQ1:=C<O AND (EMA13/EMA55>1.1 OR (C/MIN(EMA13,EMA55)>1.1)) AND EMA13>MA(EMA13,5);
JCTQ2:=REF(O,1)>=REF(C,2) AND REF(C,1)>REF(O,1) AND O<=REF(C,1) AND C>REF(O,1);
JCTQ:=JCTQ1 AND JCTQ2;
DRAWTEXT(JCTQ,(O+C)/2,'金蝉脱壳'),COLORF00FF0;
{一箭穿心}
YJCX:=CROSS(EMA55,EMA13);
DRAWTEXT(YJCX,L-0.1,'一箭穿心'),COLOR0044FF;
{步步高}
BBG1:=C>=REF(C,1) AND REF(C,1)>=REF(C,2);{3日内收盘价都比前日收盘价高}
BBG2:=V>=REF(V,1) AND REF(V,1)>=REF(V,2);{3日内量都比前日量高}
BBG3:=COUNT(C>=O,3)=3;
BBG:=BBG1 AND BBG2 AND BBG3;
DRAWTEXT(BBG AND FILTER(BBG,3),(C+O)/2,'步步高'),COLORFF00FF;
{双飞燕}
SFY1:=EMA13>EMA34 AND EMA34>EMA55;
SFY2:=REF(O,1)>=REF(C,2) AND O>=REF(C,1) AND REF(C,2)>=REF(O,2);
SFY3:=COUNT(C>O AND C/O<1.02,2)=2 OR COUNT(C<O AND O/C<1.02,2)=2;
SFY4:= V<REF(V,1);
SFY:=SFY1 AND SFY2 AND SFY3 AND SFY4;
DRAWTEXT(SFY AND FILTER(SFY,2),L,'双飞燕'),COLORYELLOW;
{三剑客}
SJK1:=EMA13>EMA34 AND EMA34>EMA55;
SJK2:=COUNT(C<=O AND O/C<1.03,3)=3 AND COUNT(ABS(1-REF(C,1)/C)<1.03,2)=2;
SJK:=SJK1 AND SJK2;
DRAWTEXT(SJK AND FILTER(SJK,3),L,'三剑客'),COLORYELLOW;
{四星望月}
SXWY1:=COUNT(C>=O AND C/O<1.03,4)=4;
SXWY2:=(ABS(EMA13-EMA34)+ABS(EMA34-EMA55))/C<0.1;{主均线相距很近或基本持平}
SXWY3:=EMA13<EMA55;
SXWY:=SXWY1 AND SXWY2 AND SXWY3;
DRAWTEXT(SXWY AND FILTER(SXWY,5),H,'四星望月'),COLOR00C5FF;
{星星点灯}
XXDD1:=ABS(1-C/O)*100<=2.5 AND H/MAX(C,O)>1.03 AND REF(C,1)/REF(O,1)>1.05;
XXDD2:=O>=REF(C,1) AND ABS(1-REF(EMA13,1)/EMA55)<0.1;
XXDD:=XXDD1 AND XXDD2;
DRAWTEXT(XXDD,(O+C)/2,'星星点灯'),COLORGREEN;
{过河拆桥}
GHCQ1:=C<O AND O/C>=1.04;
GHCQ2:=O>EMA13 AND C<EMA13;
GHCQ3:=EMA13/EMA55>1.1 AND ABS(1-EMA13/MA(EMA13,3))<0.02;
GHCQ:=GHCQ1 AND GHCQ2 AND GHCQ3;
DRAWTEXT(GHCQ,(O+C)/2,'过河拆桥'),COLORF00FF0;
{狗急跳墙}
GJTQ1:=O/REF(C,1)>1.02 AND L>REF(C,1);
GJTQ2:=V>MA(V,5);
GJTQ3:=EMA13/EMA55>1.1;
GJTQ:=GJTQ1 AND GJTQ2 AND GJTQ3;
DRAWTEXT(GJTQ,(O+C)/2,'狗急跳墙'),COLORF00FF0;
{一剑封喉}
YJFH1:=REF(C,1)>=REF(O,1);
YJFH2:=H/MAX(C,O)>=1.035 ;
YJFH3:=V/MA(REF(V,1),11)>3 AND EMA13/EMA55>1.05;
YJFH:=YJFH1 AND YJFH2 AND YJFH3;
DRAWTEXT(YJFH,(H+L)/2,'一剑封喉'),COLORF00FF0;
{小鸟依人}
XNYR1:=REF(C,1)/REF(O,1)>1.05;
XNYR2:=O<=REF(C,1) AND ABS(1-C/O)<0.02;
XNYR3:=COUNT(JGEQ OR YYSX OR HYXN,10)>=1 AND COUNT(JGEQ OR YYSX OR HYXN,2)=0;
XNYR:=XNYR1 AND XNYR2 AND XNYR3;
DRAWTEXT(XNYR,H+0.01,'小鸟依人'),COLORBLUE;
{立竿见影}
LGJY1:=O<=REF(C,1) AND V<REF(V,1) AND C<O;
LGJY2:=COUNT(JGEQ OR YYSX OR HYXN,2)=1;
LGJY:=LGJY1 AND LGJY2;
DRAWTEXT(LGJY,H+0.1,'立竿见影'),COLORBLUE;
{节外生枝}
JWSZ1:=EMA13>MAX(EMA34,EMA55) AND EMA13/EMA55>1.1 AND REF(C,1)>1.04*EMA13 AND REF(C,1)/REF(O,1)>1.04;
JWSZ2:=ABS(1-C/O)<0.015 AND ABS(1-REF(C,1)/C)<0.02;
JWSZ:=JWSZ1 AND JWSZ2;
DRAWTEXT(JWSZ,(H+C)/2,'节外生枝'),COLORF00FF0;
{笑里藏刀}
XLCD1:=REF(H,1)/MAX(REF(C,1),REF(O,1))>1.04;
XLCD2:=H<REF(H,1) AND O>=REF(C,1);
XLCD3:=EMA13/EMA55>1.05 AND C/EMA13>1.03;
XLCD:=XLCD1 AND XLCD2 AND XLCD3;
DRAWTEXT(XLCD,(O+C)/2,'笑里藏刀'),COLORF00FF0;
{马失前蹄}
MSQT1:=EMA55/EMA13>1.04 AND EMA13/C>1.03;
MSQT2:=O<=REF(L,1) AND REF(O,1)/REF(C,1)>1.03;
MSQT:= MSQT1 AND MSQT2;
DRAWTEXT(MSQT,(O+C)/2,'马失前蹄'),COLORYELLOW;
{绝处逢生}
JCFS1:=EMA55>EMA13 AND EMA13>C;
JCFS2:=O<=REF(L,1) AND C/O>1.05;
JCFS:= JCFS1 AND JCFS2;
DRAWTEXT(JCFS,H,'绝处逢生'),COLORYELLOW;
{一阴三线}
YYSX1:=C<EMA13 AND O>EMA13;{一阴三线}
YYSX2:=C<EMA34 AND O>EMA34;
YYSX3:=C<EMA55 AND O>EMA55;
YYYSX:=YYSX1 AND YYSX2 AND YYSX3;
DRAWTEXT(YYYSX,H+0.1,'一阴三线'),COLORF00FF0;
{落井下石}
LJXS1:=O<REF(L,1) AND EMA13/EMA55>1.05 AND C<O;
DRAWTEXT(LJXS1,H+0.01,'落井下石'),COLOR00C5FF;
DRAWTEXT(CROSS(EMA34,EMA13),EMA34,'分道'), COLOR00FF00;
DRAWTEXT(CROSS(EMA55,EMA13),EMA55,'穿心'), COLOR00FF00;
DRAWTEXT(CROSS(EMA55,EMA34),EMA55,'各政'), COLOR00FF00;
DRAWTEXT(CROSS(EMA13,EMA34),EMA34,'增持'),COLORRED;
DRAWTEXT(CROSS(EMA13,EMA55),EMA55,'加仓'),COLORRED;
DRAWTEXT(CROSS(EMA34,EMA55),EMA55,'重仓'),COLORRED;

EMA120:=EMA(C,120),COLORFFCC66;
AR1:=EMA55>EMA34 AND EMA34>EMA13;
AR2:=BARSLAST((C-EMA13)/EMA13*100<-6);
AR3:=EMA13>=REF(EMA13,2);
AR4:=COUNT(CROSS(C,EMA13),AR2)=1;
AR5:=AR1 AND AR2 AND AR3 AND AR4;
AR6:=AR5 AND FILTER(AR5,10);
DRAWTEXT(AR6,L,'红杏出墙'),COLORYELLOW;
STICKLINE(AR6,H,L,0.5,1),COLORYELLOW;
STICKLINE(AR6,O,C,6,1),COLORYELLOW;
BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
BR2:=ABS((EMA13-EMA34)+(EMA34-EMA55))/C<0.2;
BR3:=C>EMA55 AND (REF(C,1)<REF(EMA55,1) OR REF(C,2)<REF(EMA55,2) OR REF(C,3)<REF(EMA55,3) OR REF(C,4)<REF(EMA55,4) OR REF(C,5)<REF(EMA55,5));
BR4:=BR1 AND BR2 AND BR3;
DRAWTEXT(BR4 AND FILTER(BR4,10),L,'蚂蚁上树'),COLOR00C5FF;
STICKLINE(BR4 AND FILTER(BR4,10),H,L,0.5,1),COLOR00C5FF;
STICKLINE(BR4 AND FILTER(BR4,10),O,C,6,1),COLOR00C5FF;
CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
CR2:=V>MA(V,5)*0.6;
CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;
CR4:=ABS(EMA34-EMA55)/EMA55<0.03;
CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);
CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
STICKLINE(CR6,H,L,0.5,1),COLORF00FF0;
STICKLINE(CR6,O,C,6,1),COLORF00FF0;
DRAWTEXT(CR6,L,'红衣侠女'),COLORF00FF0;
DR1:=EMA13>EMA34 AND EMA34<EMA55;
DR2:=BARSLAST(CROSS(C,EMA55) );
DR3:=H=HHV(H,DR2);
DR4:=BARSLAST(DR3);
DR5:=COUNT(O>C AND C<REF(C,1) AND C>EMA55 AND BETWEEN((C-EMA55)/EMA55,0,0.02),DR4)=1;
DR6:=C>REF(C,1) ;
DR7:= DR1 AND DR5 AND DR6 ;
DR8:=DR7 AND FILTER(DR7 ,10);
DRAWTEXT(DR8,L,'黑客点击'),COLORD6BA63;
STICKLINE(DR8,H,L,0.5,1),COLORD6BA63;
STICKLINE(DR8,O,C,6,1),COLORD6BA63;
ER:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55);
DRAWTEXT(ER,L,'均线互换'),COLOR0099FF;
STICKLINE(ER,H,L,0.5,1),COLOR0099FF;
STICKLINE(ER,O,C,6,1),COLOR0099FF;
FR:=BARSLAST(REF(CROSS(EMA34,EMA13),1)) AND CROSS(EMA13,EMA34);
DRAWTEXT(FR,L,'梅开二度'),COLORWHITE;
STICKLINE(FR,H,L,0.5,1),COLORWHITE;
STICKLINE(FR,O,C,6,1),COLORWHITE;

HR2:=EMA13>=REF(EMA13,3) AND EMA34>=REF(EMA34,1) AND EMA55>=REF(EMA55,1) AND CROSS(C,EMA13) AND CROSS(C,EMA34) AND CROSS(C,EMA55);
DRAWTEXT(HR2 AND FILTER(HR2,10),L,'三线推进'),COLORFFC8FF;
STICKLINE(HR2 AND FILTER(HR2,10),H,L,0.5,1),COLORFFC8FF;
STICKLINE(HR2 AND FILTER(HR2,10),O,C,6,1),COLORFFC8FF;
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

 楼主| 发表于 2017-5-21 11:37 | 显示全部楼层
EMA13:MA(C,13),COLORF00FF0;
EMA34:MA(C,34),COLOR00FFFF;
EMA55:MA(C,55),COLORGREEN;

{见好就收}
Y:=(EMA13-EMA55)/EMA13*100;
JHJX:=REF(Y,1)<=10 AND Y>10;
{DRAWICON(JHJX,H,1);}
DRAWTEXT(JHJX,H,'见好就收'),COLORF00FF0;
{红杏出墙}
HX1:=EMA13<EMA34 AND EMA34<EMA55;{股价长期下跌,并且远离长期均线}
HX2:=BARSLAST((C-EMA13)/EMA13*100<-6);{收盘价在13均线%6到现在的天数}
HX3:=ABS(1-EMA55/REF(C,1))>0.1;
HX6:=BARSLAST(CROSS(EMA55,EMA34))>=20;{13日均线下降趋于走平}
HX4:=ABS(1-REF(EMA13,1)/EMA13)<0.004 AND C<EMA34;
HX5:=REF(C,1)<EMA13 AND C>EMA13 AND C>O;
HX7:=HX1 {AND HX3} AND HX4 AND HX5 ;
HX8:=HX7 AND FILTER(HX7,10);{满足后10天内不标记}
DRAWTEXT(HX8,L-0.05,'红杏出墙'),COLORYELLOW;
{黑客点击}
DJ1:=EMA13>EMA34 AND EMA34<EMA55;{13日均线大于34日均线,34日均线小于55日均线}
DJ2:=O>EMA55;{开盘价大于55日均线}
DJ3:=CROSS(EMA13,EMA55) OR ABS(1-EMA13/EMA55)<0.002;
DJ4:=O>C AND C<REF(C,1);
HKDJ:= DJ2 AND DJ3 AND DJ4;
DRAWTEXT(HKDJ AND FILTER(HKDJ,10),L-0.03,'黑客点击'),COLORD6BA63;


{红衣侠女}
XN1:=ABS(1-HHV(EMA55,5)/LLV(EMA55,5))<0.02;
XN2:=CROSS(EMA13,EMA55) OR ABS(1-EMA13/EMA55)<0.002;
XN3:=C>O AND V>REF(V,1) AND C>EMA55;
HYXN:=XN1 AND XN2 AND XN3;
DRAWTEXT(HYXN AND FILTER(HYXN,5),L-0.05,'红衣侠女'),COLORF00FF0;

{海底捞月}
LY1:=COUNT(ABS(1-EMA55/EMA34)<0.1,20)>=16;
LY2:=COUNT(CROSS(EMA34,EMA13),40)>=1 AND COUNT(CROSS(EMA55,EMA13),40)>=1;
LY3:=CROSS(EMA13,EMA55);
HDLY:=LY1 AND LY2 AND LY3;
DRAWTEXT(HDLY AND FILTER(HDLY,5),L-0.25,'海底捞月'),COLORGREEN;

{均线互换}
JXHH:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55);
DRAWTEXT(JXHH,L+0.09,'均线互换'),COLOR0099FF;
{梅开二度}
MKED1:=BARSLAST(REF(CROSS(EMA34,EMA13),1));
MKED2:=COUNT(H>=EMA55,MKED1)=MKED1;
MKED:=MKED2 AND CROSS(EMA13,EMA34);
DRAWTEXT(MKED,L-0.1,'梅开二度'),COLOR0044FF;
{一阳三线}
YY1:=C>EMA13 AND O<EMA13;
YY2:=C>EMA34 AND O<EMA34;
YY3:=C>EMA55 AND O<EMA55;
YYSX:=YY1 AND YY2 AND YY3;
DRAWTEXT(YYSX,H+0.1,'一阳三线'),COLORRED;

{揭竿而起}
MAX3:=MAX(MAX(EMA13,EMA34),EMA55);
MIN3:=MIN(MIN(EMA13,EMA34),EMA55);
JG1:=ABS(EMA13-EMA34)<C*0.05;{13线34线55线接近}
JG2:=ABS(EMA34-EMA55)<C*0.05;
JG3:=C>=O*1.03 AND C>MAX3;{阳线3%}
JG4:=O>MIN3 AND O<MAX3;
JG5:=C>REF(H,5);
JG6:=(C-EMA34)/EMA34<=0.15;{控制价高}
JG7:=V>MA(V,5) AND MA(V,10);
JGEQ:=JG1 AND JG2 AND JG3 AND JG4 AND JG5 AND JG6 AND JG7;
DRAWTEXT(JGEQ,H+0.1,'揭竿而起'),COLORGREEN;


{浪子回头}
LZ1:=REF(C,2)<REF(O,2) AND REF(C,1)<REF(O,1) AND C<O;
LZ2:=C<=REF(C,1) AND REF(C,1)<=REF(C,2);
LZ3:=MA(V,3)<REF(V,3);
LZ4:=REF(C,3)>EMA13 AND (C>EMA55 OR ABS(1-C/EMA55)<0.01);
LZHT:=LZ1 AND LZ2 AND LZ3 AND LZ4;
DRAWTEXT(LZHT AND FILTER(LZHT,5),L-0.1,'浪子回头'),COLOR00FF99;

{走四方}
ZSF1:=REF(C,4)>REF(O,4) AND (REF(C,4)>EMA13 OR REF(C,4)>EMA34) AND (ABS(1-REF(EMA55,4)/EMA55)<0.01 OR MA(EMA55,4)>REF(EMA55,5));
ZSF2:=COUNT(ABS((1-REF(C,1)/C)*100)<3,4)=4 AND MA(V,4)<REF(V,4)*0.8;
ZSF:=ZSF1 AND ZSF2;
DRAWTEXT(ZSF AND FILTER(ZSF,4),L-0.1,'走四方'),COLORBLUE;

{一枝独秀}
YZ1:=C/O>1.01 AND H/C>1.025 ;{收阳有上影}
YZ2:=EMA13>MAX(EMA34,EMA55) AND C>1.05*EMA13 AND O>MA(C,11);{昨收阳 今大于均线}
YZDX:=YZ1 AND YZ2;
DRAWTEXT(YZDX,(H+C)/2,'一枝独秀'),COLORF00FF0;

{独上高楼}
DSGL1:=REF(C,1)>=REF(O,1);
DSGL2:=O/REF(C,1)>1.029 AND O/C>1.03 AND O/MAX(EMA13,EMA55)>1.03;
DSGL:=DSGL1 AND DSGL2;
DRAWTEXT(DSGL,(O+C)/2,'独上高楼'),COLORF00FF0;

{金屋藏娇}
JWCJ1:=C<O AND REF(C,1)<REF(O,1);
JWCJ2:=O<=REF(C,1) AND L>=REF(L,1);
JWCJ3:=REF(C,1)/REF(L,1)>1.02;
JWCJ4:=EMA13<EMA34 OR EMA13<EMA55;
JWCJ:=JWCJ1 AND JWCJ2 AND JWCJ3 AND JWCJ4;
DRAWTEXT(JWCJ,LOW-0.2,'金屋藏娇'),COLORYELLOW;

{日月合璧}
RYHB1:=REF(O,1)<=REF(C,2) AND REF(C,1)<REF(O,1) AND ABS(1-REF(C,1)/REF(L,1))<0.02;
RYHB2:=C>O AND ABS(1-C/REF(O,1))<0.025 AND ABS(1-O/REF(C,1))<0.025;
RYHB3:=EMA13<REF(EMA13,1) OR ABS(1-EMA13/REF(EMA13,1))<0.01 AND (EMA13<EMA34 OR EMA13<EMA55);
RYHB4:=REF(L,1)<=LLV(REF(L,1),10);
RYHB:=RYHB1 AND RYHB2 AND RYHB3 AND RYHB4;
DRAWTEXT(RYHB ,LOW,'日月合璧'),COLORYELLOW;
{投石问路}
TSWL1:=CROSS(EMA13,EMA34) AND EMA13<EMA55;
DRAWTEXT(TSWL1,L-0.1,'投石问路'),COLOR0044FF;
{分道扬镳}
FDYB:=CROSS(EMA34,EMA13) AND EMA34>EMA55;
DRAWTEXT(FDYB,L-0.1,'分道扬镳'),COLOR0044FF;
{三军集结}
SJJJ3:=REF(EMA55,1)>REF(EMA13,1);
SJJJ4:=ABS(1-(MAX(MAX(EMA34,EMA55),EMA13)/MIN(MIN(EMA13,EMA34),EMA55)))<0.005;
SJJJ:=SJJJ3 AND SJJJ4;
DRAWTEXT(SJJJ AND FILTER(SJJJ,5),L-0.1,'三军集结'),COLOR0044FF;
{突出重围}
TCCW1:=REF(EMA55,1)<REF(EMA13,1);
TCCW2:=EMA13<LLV(REF(EMA13,1),5) AND ABS(1-(MAX(MAX(EMA34,EMA55),EMA13)/MIN(MIN(EMA13,EMA34),EMA55)))<0.008;
TCCW:=TCCW1 AND TCCW2;
DRAWTEXT(TCCW AND FILTER(TCCW,5),H+0.01,'突出重围'),COLORF00FF0;
{明修栈道}
MXZD1:=C/O>1.07;
MXZD2:=EMA13>HHV(REF(EMA13,1),5) AND V>HHV(REF(V,1),10) AND V/MA(REF(V,1),5)>2;
MXZD:=MXZD1 AND MXZD2;
DRAWTEXT(MXZD,H+0.01,'明修栈道'),COLORF00FF0;
{暗度陈仓}
ADCC1:=O/C>1.05 AND EMA13/EMA55<1.1 AND EMA13>MA(EMA13,5);
ADCC2:=O/REF(C,1)<1.03;{V<HHV(REF(V,1),5) AND V/MA(REF(V,1),5)<2};
ADCC:=ADCC1 AND ADCC2;
DRAWTEXT(ADCC,(C+O)/2,'暗度陈仓'),COLOR00C5FF;
{破镜重圆}
PJCY1:=REF(O,1)/REF(C,1)>1.02;
PJCY2:=O<=REF(C,1) AND C>=REF(O,1);
PJCY3:=(ABS(1-REF(C,1)/EMA55)<0.05 OR ABS(1-C/EMA55)<0.05 OR ABS(1-MA(C,2)/EMA55)<0.05);
PJCY4:=EMA13>EMA55 OR EMA13>MA(EMA13,5);
PJCY:=PJCY1 AND PJCY2 AND PJCY3 AND PJCY4;
DRAWTEXT(PJCY,LOW,'破镜重圆'),COLORYELLOW;
{一石二鸟}
YSEN1:=REF(C,2)>REF(O,2) AND REF(C,1)<REF(O,1) AND C<O;
YSEN2:=REF(C,2)>EMA55 AND EMA13>EMA55 AND EMA13>=MA(EMA13,5);
YSEN3:=REF(V,2)>REF(V,1) AND REF(V,2)>V;
YSEN:=YSEN1 AND YSEN2 AND YSEN3;
DRAWTEXT(YSEN,H+0.01,'一石二鸟'),COLORBLUE;
{拖泥带水}
TNDS1:=O/REF(C,1)>1.05 AND MIN(C,O)/L>1.03;
TNDS2:=C/MAX(EMA13,EMA55)>1.03 AND C>REF(C,1);
TNDS:=TNDS1 AND TNDS2;
DRAWTEXT(TNDS,(O+C)/2,'拖泥带水'),COLORF00FF0;
{金蝉脱壳}
JCTQ1:=C<O AND (EMA13/EMA55>1.1 OR (C/MIN(EMA13,EMA55)>1.1)) AND EMA13>MA(EMA13,5);
JCTQ2:=REF(O,1)>=REF(C,2) AND REF(C,1)>REF(O,1) AND O<=REF(C,1) AND C>REF(O,1);
JCTQ:=JCTQ1 AND JCTQ2;
DRAWTEXT(JCTQ,(O+C)/2,'金蝉脱壳'),COLORF00FF0;
{一箭穿心}
YJCX:=CROSS(EMA55,EMA13);
DRAWTEXT(YJCX,L-0.1,'一箭穿心'),COLOR0044FF;
{步步高}
BBG1:=C>=REF(C,1) AND REF(C,1)>=REF(C,2);{3日内收盘价都比前日收盘价高}
BBG2:=V>=REF(V,1) AND REF(V,1)>=REF(V,2);{3日内量都比前日量高}
BBG3:=COUNT(C>=O,3)=3;
BBG:=BBG1 AND BBG2 AND BBG3;
DRAWTEXT(BBG AND FILTER(BBG,3),(C+O)/2,'步步高'),COLORFF00FF;
{双飞燕}
SFY1:=EMA13>EMA34 AND EMA34>EMA55;
SFY2:=REF(O,1)>=REF(C,2) AND O>=REF(C,1) AND REF(C,2)>=REF(O,2);
SFY3:=COUNT(C>O AND C/O<1.02,2)=2 OR COUNT(C<O AND O/C<1.02,2)=2;
SFY4:= V<REF(V,1);
SFY:=SFY1 AND SFY2 AND SFY3 AND SFY4;
DRAWTEXT(SFY AND FILTER(SFY,2),L,'双飞燕'),COLORYELLOW;
{三剑客}
SJK1:=EMA13>EMA34 AND EMA34>EMA55;
SJK2:=COUNT(C<=O AND O/C<1.03,3)=3 AND COUNT(ABS(1-REF(C,1)/C)<1.03,2)=2;
SJK:=SJK1 AND SJK2;
DRAWTEXT(SJK AND FILTER(SJK,3),L,'三剑客'),COLORYELLOW;
{四星望月}
SXWY1:=COUNT(C>=O AND C/O<1.03,4)=4;
SXWY2:=(ABS(EMA13-EMA34)+ABS(EMA34-EMA55))/C<0.1;{主均线相距很近或基本持平}
SXWY3:=EMA13<EMA55;
SXWY:=SXWY1 AND SXWY2 AND SXWY3;
DRAWTEXT(SXWY AND FILTER(SXWY,5),H,'四星望月'),COLOR00C5FF;
{星星点灯}
XXDD1:=ABS(1-C/O)*100<=2.5 AND H/MAX(C,O)>1.03 AND REF(C,1)/REF(O,1)>1.05;
XXDD2:=O>=REF(C,1) AND ABS(1-REF(EMA13,1)/EMA55)<0.1;
XXDD:=XXDD1 AND XXDD2;
DRAWTEXT(XXDD,(O+C)/2,'星星点灯'),COLORGREEN;
{过河拆桥}
GHCQ1:=C<O AND O/C>=1.04;
GHCQ2:=O>EMA13 AND C<EMA13;
GHCQ3:=EMA13/EMA55>1.1 AND ABS(1-EMA13/MA(EMA13,3))<0.02;
GHCQ:=GHCQ1 AND GHCQ2 AND GHCQ3;
DRAWTEXT(GHCQ,(O+C)/2,'过河拆桥'),COLORF00FF0;
{狗急跳墙}
GJTQ1:=O/REF(C,1)>1.02 AND L>REF(C,1);
GJTQ2:=V>MA(V,5);
GJTQ3:=EMA13/EMA55>1.1;
GJTQ:=GJTQ1 AND GJTQ2 AND GJTQ3;
DRAWTEXT(GJTQ,(O+C)/2,'狗急跳墙'),COLORF00FF0;
{一剑封喉}
YJFH1:=REF(C,1)>=REF(O,1);
YJFH2:=H/MAX(C,O)>=1.035 ;
YJFH3:=V/MA(REF(V,1),11)>3 AND EMA13/EMA55>1.05;
YJFH:=YJFH1 AND YJFH2 AND YJFH3;
DRAWTEXT(YJFH,(H+L)/2,'一剑封喉'),COLORF00FF0;
{小鸟依人}
XNYR1:=REF(C,1)/REF(O,1)>1.05;
XNYR2:=O<=REF(C,1) AND ABS(1-C/O)<0.02;
XNYR3:=COUNT(JGEQ OR YYSX OR HYXN,10)>=1 AND COUNT(JGEQ OR YYSX OR HYXN,2)=0;
XNYR:=XNYR1 AND XNYR2 AND XNYR3;
DRAWTEXT(XNYR,H+0.01,'小鸟依人'),COLORBLUE;
{立竿见影}
LGJY1:=O<=REF(C,1) AND V<REF(V,1) AND C<O;
LGJY2:=COUNT(JGEQ OR YYSX OR HYXN,2)=1;
LGJY:=LGJY1 AND LGJY2;
DRAWTEXT(LGJY,H+0.1,'立竿见影'),COLORBLUE;
{节外生枝}
JWSZ1:=EMA13>MAX(EMA34,EMA55) AND EMA13/EMA55>1.1 AND REF(C,1)>1.04*EMA13 AND REF(C,1)/REF(O,1)>1.04;
JWSZ2:=ABS(1-C/O)<0.015 AND ABS(1-REF(C,1)/C)<0.02;
JWSZ:=JWSZ1 AND JWSZ2;
DRAWTEXT(JWSZ,(H+C)/2,'节外生枝'),COLORF00FF0;
{笑里藏刀}
XLCD1:=REF(H,1)/MAX(REF(C,1),REF(O,1))>1.04;
XLCD2:=H<REF(H,1) AND O>=REF(C,1);
XLCD3:=EMA13/EMA55>1.05 AND C/EMA13>1.03;
XLCD:=XLCD1 AND XLCD2 AND XLCD3;
DRAWTEXT(XLCD,(O+C)/2,'笑里藏刀'),COLORF00FF0;
{马失前蹄}
MSQT1:=EMA55/EMA13>1.04 AND EMA13/C>1.03;
MSQT2:=O<=REF(L,1) AND REF(O,1)/REF(C,1)>1.03;
MSQT:= MSQT1 AND MSQT2;
DRAWTEXT(MSQT,(O+C)/2,'马失前蹄'),COLORYELLOW;
{绝处逢生}
JCFS1:=EMA55>EMA13 AND EMA13>C;
JCFS2:=O<=REF(L,1) AND C/O>1.05;
JCFS:= JCFS1 AND JCFS2;
DRAWTEXT(JCFS,H,'绝处逢生'),COLORYELLOW;
{一阴三线}
YYSX1:=C<EMA13 AND O>EMA13;{一阴三线}
YYSX2:=C<EMA34 AND O>EMA34;
YYSX3:=C<EMA55 AND O>EMA55;
YYYSX:=YYSX1 AND YYSX2 AND YYSX3;
DRAWTEXT(YYYSX,H+0.1,'一阴三线'),COLORF00FF0;
{落井下石}
LJXS1:=O<REF(L,1) AND EMA13/EMA55>1.05 AND C<O;
DRAWTEXT(LJXS1,H+0.01,'落井下石'),COLOR00C5FF;
DRAWTEXT(CROSS(EMA34,EMA13),EMA34,'分道'), COLOR00FF00;
DRAWTEXT(CROSS(EMA55,EMA13),EMA55,'穿心'), COLOR00FF00;
DRAWTEXT(CROSS(EMA55,EMA34),EMA55,'各政'), COLOR00FF00;
DRAWTEXT(CROSS(EMA13,EMA34),EMA34,'增持'),COLORRED;
DRAWTEXT(CROSS(EMA13,EMA55),EMA55,'加仓'),COLORRED;
DRAWTEXT(CROSS(EMA34,EMA55),EMA55,'重仓'),COLORRED;

EMA120:=EMA(C,120),COLORFFCC66;
AR1:=EMA55>EMA34 AND EMA34>EMA13;
AR2:=BARSLAST((C-EMA13)/EMA13*100<-6);
AR3:=EMA13>=REF(EMA13,2);
AR4:=COUNT(CROSS(C,EMA13),AR2)=1;
AR5:=AR1 AND AR2 AND AR3 AND AR4;
AR6:=AR5 AND FILTER(AR5,10);
DRAWTEXT(AR6,L,'红杏出墙'),COLORYELLOW;
STICKLINE(AR6,H,L,0.5,1),COLORYELLOW;
STICKLINE(AR6,O,C,6,1),COLORYELLOW;
BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
BR2:=ABS((EMA13-EMA34)+(EMA34-EMA55))/C<0.2;
BR3:=C>EMA55 AND (REF(C,1)<REF(EMA55,1) OR REF(C,2)<REF(EMA55,2) OR REF(C,3)<REF(EMA55,3) OR REF(C,4)<REF(EMA55,4) OR REF(C,5)<REF(EMA55,5));
BR4:=BR1 AND BR2 AND BR3;
DRAWTEXT(BR4 AND FILTER(BR4,10),L,'蚂蚁上树'),COLOR00C5FF;
STICKLINE(BR4 AND FILTER(BR4,10),H,L,0.5,1),COLOR00C5FF;
STICKLINE(BR4 AND FILTER(BR4,10),O,C,6,1),COLOR00C5FF;
CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
CR2:=V>MA(V,5)*0.6;
CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;
CR4:=ABS(EMA34-EMA55)/EMA55<0.03;
CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);
CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
STICKLINE(CR6,H,L,0.5,1),COLORF00FF0;
STICKLINE(CR6,O,C,6,1),COLORF00FF0;
DRAWTEXT(CR6,L,'红衣侠女'),COLORF00FF0;
DR1:=EMA13>EMA34 AND EMA34<EMA55;
DR2:=BARSLAST(CROSS(C,EMA55) );
DR3:=H=HHV(H,DR2);
DR4:=BARSLAST(DR3);
DR5:=COUNT(O>C AND C<REF(C,1) AND C>EMA55 AND BETWEEN((C-EMA55)/EMA55,0,0.02),DR4)=1;
DR6:=C>REF(C,1) ;
DR7:= DR1 AND DR5 AND DR6 ;
DR8:=DR7 AND FILTER(DR7 ,10);
DRAWTEXT(DR8,L,'黑客点击'),COLORD6BA63;
STICKLINE(DR8,H,L,0.5,1),COLORD6BA63;
STICKLINE(DR8,O,C,6,1),COLORD6BA63;
ER:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55);
DRAWTEXT(ER,L,'均线互换'),COLOR0099FF;
STICKLINE(ER,H,L,0.5,1),COLOR0099FF;
STICKLINE(ER,O,C,6,1),COLOR0099FF;
FR:=BARSLAST(REF(CROSS(EMA34,EMA13),1)) AND CROSS(EMA13,EMA34);
DRAWTEXT(FR,L,'梅开二度'),COLORWHITE;
STICKLINE(FR,H,L,0.5,1),COLORWHITE;
STICKLINE(FR,O,C,6,1),COLORWHITE;

HR2:=EMA13>=REF(EMA13,3) AND EMA34>=REF(EMA34,1) AND EMA55>=REF(EMA55,1) AND CROSS(C,EMA13) AND CROSS(C,EMA34) AND CROSS(C,EMA55);
DRAWTEXT(HR2 AND FILTER(HR2,10),L,'三线推进'),COLORFFC8FF;
STICKLINE(HR2 AND FILTER(HR2,10),H,L,0.5,1),COLORFFC8FF;
STICKLINE(HR2 AND FILTER(HR2,10),O,C,6,1),COLORFFC8FF;
回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2017-7-20 12:54 | 显示全部楼层
好多呀,像程序代码,IT
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册会员 新浪微博登陆

本版积分规则

QQ|小黑屋|手机版|海风股票论坛 ( 闽ICP备05030991号-1 )|网站地图

GMT+8, 2017-11-21 20:04

 
快速回复 返回顶部 返回列表