请选择 进入手机版 | 继续访问电脑版
查看: 6551|回复: 34

根据论坛里三位前辈公式组合发现的……

[复制链接]

新浪微博达人勋

三级海风会员

发表于 2011-11-20 20:37 | 显示全部楼层 |阅读模式

马上注册海风会员,享受更多便捷服务!

您需要 登录 才可以下载或查看,没有帐号?注册会员 新浪微博登陆

x
新人报道!呵呵,根据论坛里三位前辈的公式组合后发现的规律,发现很稳定,大家可以试试,另外本人愚钝,只能搞出前面两个选股公式,第三个实在是没办法弄出来了:(
黑马选股
个股:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
大盘:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
con1:=cross(个股,9);
Var1:=EMA(CLOSE,3);
Var2:=EMA(CLOSE,21);
Var3:=BARSLAST(CROSS(Var2,Var1))>15;
Var4:=VOL>MA(VOL,5)*2 AND VOL<MA(VOL,5)*5;
con2:=CROSS(Var1,Var2) AND Var4 AND Var3;
con1 or con2;

建仓选股
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
AA:VAR8>REF(VAR8,1);

有不对的地方还望大家指正














.

[ 本帖最后由 lx7999 于 2012-1-26 06:23 编辑 ]

评分

参与人数 1等级分 +30 现金 +300 收起 理由
黑夜鬼 + 30 + 300 欢迎来到股软,加分鼓励。

查看全部评分

黄金广告位招租
回复

使用道具 举报

新浪微博达人勋

初级海风会员

发表于 2011-11-21 09:47 | 显示全部楼层
:) 指标不错   谢谢贡献
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2011-11-21 12:56 | 显示全部楼层
第三个楼主发来看看。,, 不过前两个信号太多
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2011-11-21 23:28 | 显示全部楼层

指标不错

指标不错  :lol
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

 楼主| 发表于 2011-11-21 23:47 | 显示全部楼层
藕就是水瓶不行,搞不出第三个滴选股公式:( 信号多不怕滴,你不管它有多少信号,只管三个指标都发出买入信号,就可以进了,只是能赚多少就不知道了:lol 看看我发的那两个图里面用红色长方框标出来的地方就是三个指标都发出了买入信号,我对比过历史数据,发现都有赚,只是赚多赚少的问题
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2011-11-23 11:59 | 显示全部楼层
谢谢分享研究,再接再厉
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2011-11-23 22:25 | 显示全部楼层
第三个公式是什么公式啊?一头雾水
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

发表于 2011-11-23 22:43 | 显示全部楼层
厉害 厉害
形成组合拳了。
我入市了,如果没有套牢,就好好抄下去.
回复 支持 反对

使用道具 举报

新浪微博达人勋

八级海风会员

发表于 2011-11-24 08:46 | 显示全部楼层
哈哈  先试试  谢谢!!
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

 楼主| 发表于 2011-12-9 09:34 | 显示全部楼层
自从发现这三个指标以来,等了半个多月终于等到第一个同时满足这三个指标都发出买入信号的股票!等得藕内牛满面啊!
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2011-12-10 14:58 | 显示全部楼层
谢谢朋友的辛勤劳动成果
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

 楼主| 发表于 2011-12-22 00:26 | 显示全部楼层
不知道怎么回事哈,我每天都有做当天的收盘作业,我记得在16、19号两天做完作业都有看过,都没发这几个股票的量价合一趋势指标里面有出现那个牛字,今天因为大盘走弱,没心思看股票,所以就在手动一个个漫漫往下翻股票,结果却发现竟然在16号有6只股票、19号有一只股票这三个指标同时发出了买入信号,郁闷哦!:L
北斗.jpg
超日.jpg
东方.jpg
华伍.jpg
精功.jpg
新钢.jpg
中海.jpg
回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2011-12-22 13:31 | 显示全部楼层
楼主的前两个公式和您的副图上的指标不一致!
这是第三个公式:

A:=IF((CLOSE > 126.32),(AMOUNT / 100000),VOL);
MA(A,120),COLOR996633,POINTDOT;
MA(A,2),COLORYELLOW,POINTDOT;
游资:MA(A,3),COLOR3399FF,POINTDOT;
主力:MA(A,8),COLORGREEN,POINTDOT;
大户:MA(A,13),COLORRED,POINTDOT;
散户:MA(A,27),COLORF2E9E7,POINTDOT;
STICKLINE(MA(A,2)>0,0,MA(A,2),2,1),COLORYELLOW;
STICKLINE(游资>0,0,游资,2,1),COLOR3399FF;
STICKLINE(主力>0,0,主力,2,1),COLORGREEN;
STICKLINE(大户>0,0,大户,2,1),COLORRED;
STICKLINE(散户>0,0,散户,2,1),COLORF2E9E7;
RS1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))
*REFDATE(HHV(V,100),DATE)*1.3-REFDATE(HHV(V,100),DATE)/6;
STICKLINE(SMA(RS1,5,1)>SMA(SMA(RS1,5,1),10,1),SMA(RS1,5,1),
SMA(SMA(RS1,5,1),10,1),1,-1),COLORFF00FF;
STICKLINE(SMA(RS1,5,1)<=SMA(SMA(RS1,5,1),10,1),SMA(RS1,5,1),
SMA(SMA(RS1,5,1),10,1),1,-1),COLORGREEN;

VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
EMA5:=EMA(C,5);
EMA13:=EMA(C,9);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(EMA13,EMA5))+1),LLV(L,BARSLAST(CROSS
(EMA13,EMA5))+1),H=HHV(H,BARSLAST(CROSS(EMA5,EMA13))+1),HHV(H,BARSLAST(CROSS
(EMA5,EMA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(EMA5,EMA13))+1),HHV(H,BARSLAST(CROSS
(EMA5,EMA13))+1),L=LLV(L,BARSLAST(CROSS(EMA13,EMA5))+1),LLV(L,BARSLAST(CROSS
(EMA13,EMA5))+1),0),COLOR00FF00;

HRY33:=SQRT((HHV(HIGH,55)*LLV(LOW,55)));
TJ33:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
STICKLINE(TJ33,0,散户,5,0),COLOR008888;
STICKLINE(TJ33,0,散户,0.2,0),COLOR00FFFF;
DRAWTEXT(TJ33,散户,'牛'),COLOR00FFFF;



aaaa.gif

评分

参与人数 1等级分 +29 现金 +291 收起 理由
子路 + 29 + 291 感谢提供原码!

查看全部评分

回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

 楼主| 发表于 2011-12-22 15:55 | 显示全部楼层
楼上滴看清楚藕发滴是选股指标,并不是辅图的公式指标,辅图的三个公式指标论坛里面都有,我就不再重复发了:L
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

 楼主| 发表于 2011-12-22 15:56 | 显示全部楼层
还有第三个辅图的选股指标因为藕做不出来,所以没办法发出来:(
回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2011-12-22 21:39 | 显示全部楼层
就是用你贴的公式,并没改动,下面是不同的地方:


北斗星通:
aaaa.JPG

超日太阳:
bbbb.JPG

东方日升:
cccc.JPG

华伍股份:
dddd.JPG

精功科技:
eeee.JPG

新钢股份:
ffff.JPG

中海科技:
gggg.JPG
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

发表于 2011-12-23 08:15 | 显示全部楼层
楼主。。能否把公式再重新发一下呢?
回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2011-12-23 16:43 | 显示全部楼层
建仓:

VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=EMA(CLOSE,5);
VAR10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
A:IF(VAR9>REF(VAR9,1),VAR9,0),COLORBLUE,LINETHICK0;
B:IF(VAR9>REF(VAR9,1),VAR9,0),COLOR1010FF,LINETHICK0;
STICKLINE(VAR8>REF(VAR8,1),0,VAR8,4,1),COLOR10FFFF;
进:IF(VAR8>REF(VAR8,1),VAR8*8,0),COLOR10FFFF,LINETHICK0;
STICKLINE(VAR8<REF(VAR8,1),0,VAR8,4,1),COLORFFF810;
洗:IF(VAR8<REF(VAR8,1),VAR8*10,0),COLORFFF810,LINETHICK0;
持:(LOW*5),COLORFF10FF,LINETHICK0;
差:VAR10,COLORFF7676;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
STICKLINE(XL3,0,VAR8*3,4,0),COLOR006EFF;
DRAWTEXT(XL3,VAR8*2,'买'),COLORRED;
↑买:DRAWICON(XL3,0,4),COLORRED;
R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(R,3,1),COLORRED;
M:SMA(K,3,1),COLORYELLOW;
IF(K<M,K,DRAWNULL),COLORCYAN;
A1:=K>=REF(K,1) AND C<=REF(C,1) AND L=LLV(L,9);
DRAWICON(A1,K,1),COLORRED;
B1:=K<=REF(K,1) AND C>=REF(C,1) AND H=HHV(H,9);
DRAWICON(B1,K,2),COLORGREEN;
金叉:IF(M<20 AND CROSS(K,M),40,0),COLORRED;
回生:IF(BARSLAST(金叉)<=9 AND BARSLAST(金叉)>2 AND CROSS(M,K) AND M<30,60,0);


黑马:

个股:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),COLOR1010FF;
大盘:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),COLORE67010,LINETHICK2;
黑马初现:IF(CROSS(个股,9),50,0),STICK,LINETHICK3,COLOR00FF00;
DRAWTEXT(CROSS(个股,9),66,'黑马初现'),COLOR00FF00;
DRAWTEXT(CROSS(个股,9),60,'1'),COLOR00FF00;
VAR1:=EMA(CLOSE,3);
VAR2:=EMA(CLOSE,21);
VAR3:=BARSLAST(CROSS(VAR2,VAR1))>15;
VAR4:=VOL>MA(VOL,5)*2 AND VOL<MA(VOL,5)*5;
VAR5:=CROSS(VAR1,VAR2) AND VAR4 AND VAR3;
黑马:IF(VAR5,60,0),STICK,LINETHICK3,COLORF00FF0;
DRAWTEXT(VAR5,78,'黑马!'),COLORF00FF0;


hhhh.jpg
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2011-12-24 13:02 | 显示全部楼层
偶菜菜,看不懂,是不是先要搞清楚指标的含义呀,但支持是肯定的了,谢谢了
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

 楼主| 发表于 2011-12-24 14:47 | 显示全部楼层
不用搞清楚指标含义滴!你只要看见下面滴三个辅图指标都发出买入信号了,那么你就可以在当天下午即将收盘滴罪后几分钟或者第二天开盘后选个相对于当天的低位买进,正常情况下只要你不是贪心,一般5%~10%的利润都还是能保证滴:lol

注意:只要当天没收盘,那么当天出现的这些指标都有可能会变!!!
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2011-12-25 15:50 | 显示全部楼层
原帖由 坏老公 于 2011-12-24 14:47 发表
不用搞清楚指标含义滴!你只要看见下面滴三个辅图指标都发出买入信号了,那么你就可以在当天下午即将收盘滴罪后几分钟或者第二天开盘后选个相对于当天的低位买进,正常情况下只要你不是贪心,一般5%~10%的利润都还是 ...

谢谢啊!收盘前几分钟一只一只地从2000多股票中去发现符合条件的可不是件容易的事.如果有选股公式能事先关注就好了
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

 楼主| 发表于 2011-12-25 21:53 | 显示全部楼层
晕菜~感情阁下没看我发在一楼的帖子?认真看完我发在一楼的帖子再说话好不?
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2011-12-25 23:30 | 显示全部楼层
原帖由 坏老公 于 2011-12-25 21:53 发表
晕菜~感情阁下没看我发在一楼的帖子?认真看完我发在一楼的帖子再说话好不?

  不好意思啊,我看了你发在一楼的帖子,但偶笨笨不会弄啊,感觉那是做在副图上的指标,可是怎么选出符合条件的呢?
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

发表于 2011-12-27 12:39 | 显示全部楼层
原帖由 731 于 2011-12-22 13:31 发表
楼主的前两个公式和您的副图上的指标不一致!
这是第三个公式:

A:=IF((CLOSE > 126.32),(AMOUNT / 100000),VOL);
MA(A,120),COLOR996633,POINTDOT;
MA(A,2),COLORYELLOW,POINTDOT;
游资:MA(A,3),COLOR3399FF,P ...

这个公式里面有这一句:
RS1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*REFDATE(HHV(V,100),DATE)*1.3-REFDATE(HHV(V,100),DATE)/6;
这一句中用了一个比较特殊的函数 REFDATE(X,DATE),含义是:特定日期日DATE的X值。
比如REFDATE(C,1010203),表示2001(1900+101)年02月03日的收盘价。
问题是这个DATE,公式中没有定义,事实上取的就是今天(但不是当天!)。这样问题就来了,比如说:
A:C;
这一句,定义A为当天收盘价,画出来的线,是每一天的收盘价的曲线。
但是
A:REFDATE(C,DATE);
这一句,定义A为今天收盘价,画出来的线,是今天,也就是K线上最后一天的收盘价的一根水平线。
也就是说,相对于前面的日子来说,后一种写法,事实上是产生了信号漂移了。严格来说,这种写法是用最后一天的值,去修改了前面的信号,是有未来的。
这也就回答了坏老公问的这个问题“不知道怎么回事哈,我每天都有做当天的收盘作业,我记得在16、19号两天做完作业都有看过,都没发这几个股票的量价合一趋势指标里面有出现那个牛字,今天因为大盘走弱,没心思看股票,所以就在手动一个个漫漫往下翻股票,结果却发现竟然在16号有6只股票、19号有一只股票这三个指标同时发出了买入信号,郁闷哦!”

[ 本帖最后由 子路 于 2011-12-27 12:45 编辑 ]

评分

参与人数 1等级分 +30 现金 +300 收起 理由
黑夜鬼 + 30 + 300 精品文章

查看全部评分

股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

发表于 2011-12-27 12:50 | 显示全部楼层
原帖由 坏老公 于 2011-12-24 14:47 发表
不用搞清楚指标含义滴!你只要看见下面滴三个辅图指标都发出买入信号了,那么你就可以在当天下午即将收盘滴罪后几分钟或者第二天开盘后选个相对于当天的低位买进,正常情况下只要你不是贪心,一般5%~10%的利润都还是 ...

个人不赞同第一句话。我个人理解,从来没有神仙指标,可以在不了解指标含义的情况下,只要看见信号,就可以买入。
当然,这个市场是复杂的,每个人都可以有每个人的方法,我的个人理解只作为一种交流提出。股市不是高考题目,没有对错,只有输赢。欢迎多交流!(:0047:)
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

六级海风会员

发表于 2011-12-27 14:06 | 显示全部楼层
原帖由 子路 于 2011-12-27 12:39 发表

这个公式里面有这一句:
RS1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*REFDATE(HHV(V,100),DATE)*1.3-REFDATE(HHV(V,100),DATE)/6;
这一句中用了一个比较特殊的函数 REFDATE(X,DATE),含义是:特定日期 ...

精彩  谁给版主加分呢
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

发表于 2011-12-28 20:04 | 显示全部楼层
原帖由 子路 于 2011-12-27 12:39 发表

这个公式里面有这一句:
RS1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*REFDATE(HHV(V,100),DATE)*1.3-REFDATE(HHV(V,100),DATE)/6;
这一句中用了一个比较特殊的函数 REFDATE(X,DATE),含义是:特定日期 ...

三言两语就把那么复杂的公式说的很明白,那都是台下的功课做的好啊:handshake
对自己好点,因为一辈子不长;对身边的人好点,因为下辈子不一定能够遇见!
回复 支持 反对

使用道具 举报

新浪微博达人勋

六级海风会员

发表于 2011-12-29 14:42 | 显示全部楼层
原帖由 坏老公 于 2011-12-22 00:26 发表
不知道怎么回事哈,我每天都有做当天的收盘作业,我记得在16、19号两天做完作业都有看过,都没发这几个股票的量价合一趋势指标里面有出现那个牛字,今天因为大盘走弱,没心思看股票,所以就在手动一个个漫漫往下翻股 ...



通达信不同于分析家、飞狐。分析家、飞狐画线函数DRAWLINE不能参与运算,通达信则可以。而TJ33:=(REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33);
显然用画线函数参与运算了,这就牵扯到线画完没画完。
例如:002261拓维信息的画线只画到12月15日。那么15日之后即使有符合条件的低点也选不出股来。等这条线画全了就可能显示出15日以后有木有黄柱子了。
另外:用同一公式,在不同的股软上选股。选出的股票个数一般不相同。总有多的、有遗漏的。

评分

参与人数 1等级分 +29 现金 +291 收起 理由
子路 + 29 + 291 原创内容

查看全部评分

回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2011-12-31 08:29 | 显示全部楼层
学习中,把第三个指标贴上来看看,应该能编出选股公式的
回复 支持 反对

使用道具 举报

新浪微博达人勋

初级海风会员

发表于 2012-1-1 17:31 | 显示全部楼层
谢谢分享研究,再接再厉
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册会员 新浪微博登陆

本版积分规则

QQ|小黑屋|手机版|海风股票论坛 ( 闽ICP备05030991号-1 )|网站地图

GMT+8, 2017-10-17 19:16

 
快速回复 返回顶部 返回列表