请选择 进入手机版 | 继续访问电脑版
查看: 7508|回复: 21

对传统指标 MACD 的改造利用并研讨

[复制链接]

新浪微博达人勋

七级海风会员

发表于 2011-9-28 13:28 | 显示全部楼层 |阅读模式

马上注册海风会员,享受更多便捷服务!

您需要 登录 才可以下载或查看,没有帐号?注册会员 新浪微博登陆

x
大盘疲软,不看也罢,明天午后或许有机会。

MACD 指标流传至今,且国内外很多人在用,确有其独到之处;
但其滞后性,也给实战带来不便;
问题在于用到 EMA 12,26 ,虽然平滑,波动性较小,但其的拐头往往滞后,
现改用 SMA 替代,感觉有一定改善;
但还有些不够完善,特供股友研讨。

{公式是 DZH_L2 的,其它股软要作些改动}
JJ:=IF(C>200 OR VOL=0,(L+H+2*O+3*C)/7,AMOUNT/(VOL*100));
M1:=SMA(JJ,155,21);
M2:=SMA(JJ,455,21);
M3:=SMA(JJ,255,21);
M4:=SMA(JJ,655,21);
M5:=SMA(JJ,355,21);
M6:=SMA(JJ,855,21);
短:(M1-M2),COLORCCFFFF,layer0;
短1:EMA(短,5),COLOR58FF58,layer0;
中:M3-M4,COLOR00FFFF,LINETHICK2;
中1:EMA(中,7),COLORFF00FF;
MACD:=2*(中-中1);
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,6,1),COLOR1011FF;
STICKLINE(MACD>=0 AND MACD< REF(MACD,1),0,MACD,6,0),COLOR1088FF;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,6,1),COLORFFFFa0;
STICKLINE(MACD<0 AND MACD< REF(MACD,1),0,MACD,6,0),COLORFFcd00;
FILLRGN(中,0,中>0 AND 中>中1 AND 中>REF(中,1),rgb(88,10,0)),layer7;
FILLRGN(中,0,中<0 AND 中<中 AND 中<REF(中,1),rgb(15,80,20)),layer7;
PARTLINE(中,中<REF(中,1),RGB(0,120,0)),LINETHICK2;
C1:=EMA(JJ,5);
C3:=BARSLAST(REF(CROSS(短,短1),1));
C4:=BARSLAST(REF(CROSS(短1,短1),1));
DRAWTEXT(REF(C1,C3+1)>C1 AND REF(短,C3+1)<短 AND CROSS(短,短1)>0,REF(短,1)*1.1,'背'),color00FFFF,ALIGN1;
DRAWTEXT(REF(C1,C4+1)<C1 AND REF(短,C4+1)>短 AND CROSS(短1,短)>0,REF(短,1)*1.2,'背'),color00FF00,ALIGN1;
长:M5-M6,COLORFFFF00,LINETHICK2;
长1:EMA(长,7),COLOR0022FF;
MR:IF(CROSS(中,中1) AND 短<0 AND REF(短,1)>REF(中,1) AND REF(中,1)>REF(长,1),MAX(HHV(短,120),-短),0),COLORAA00FF;
MC:IF(CROSS(中1,中) AND LAST(短>0)>9 AND REF(短,1)<REF(中,1) AND REF(中,1)<REF(长,1),MIN(LLV(短,120),-短),0),COLORFFFFFF;

大盘图:
20110928.jpg

评分

参与人数 1等级分 +10 收起 理由
sigma + 10 我很赞同

查看全部评分

黄金广告位招租
回复

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2011-9-28 13:35 | 显示全部楼层
龙兄论述非常精辟、值得借鉴!我欣赏!恭祝老兄十一节日快乐!
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

 楼主| 发表于 2011-9-28 13:35 | 显示全部楼层
补充说明:
DZH 中,LAYER 0~7  函数 是指画面层数,数值小则画面在前;
主要为了画面清晰,可删除。
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

 楼主| 发表于 2011-9-28 14:02 | 显示全部楼层
MACD 之二:

DIFF:=EMA(CLOSE,12*2)-EMA(CLOSE,26*2);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
MACDZ1:=SUM(MACD,0);
PARTLINE(MACDZ1,MACDZ1>REF(MACDZ1,1),RGB(250,0,0),MACDZ1<REF(MACDZ1,1),RGB(0,250,0)),linethick4;
DIFF1:=EMA(CLOSE,12*3)-EMA(CLOSE,26*3);
DEA1:=EMA(DIFF1,11);
MACD1:=2*(DIFF1-DEA1);
MACDZ2:=SUM(MACD1,0);
PARTLINE(MACDZ2,MACDZ2>REF(MACDZ2,1),RGB(250,0,250),MACDZ2<REF(MACDZ2,1),RGB(0,250,250)),linethick2;
0,COLOR909090;

20110928A.jpg

评分

参与人数 1等级分 +30 现金 +290 收起 理由
子路 + 30 + 290 原创内容

查看全部评分

回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

 楼主| 发表于 2011-9-28 14:30 | 显示全部楼层
(上面的之二也可在分时图中用)
MACD 之三: (该公式离 MACD 远了点)
{三线看盘}
JJ0:=AMOUNT/(VOL*100);
JJ:=IF(C>JJ0*2 OR C<JJ0*2,(L+H+2*O+3*C)/7,JJ0);
短线:EMA(((EMA(C,5)-EMA(C,10))/EMA(C,10))*100,3),color00AA00;
中线:EMA((EMA(C,10)-EMA(C,21))/EMA(C,21)*100,3),color009999;
长线:EMA((EMA(C,21)-EMA(C,45))/EMA(C,45)*100,3),color990099;
0,color888888;
中线1:=EMA(中线,2);
C1:=EMA(jj,7);
C2:=CROSS(中线1,REF(中线1,1));
C5:=CROSS(REF(中线1,1),中线1);
C3:=BARSLAST(REF(C2,1));
C4:=BARSLAST(REF(C5,1));
DRAWTEXT(REF(C1,C3+1)>C1 AND REF(中线1,C3+1)<中线 AND C2>0,中线,'背'),color00ffff;
DRAWTEXT(REF(C1,C4+1)<C1 AND REF(中线,C4+1)>中线 AND C5>0,中线,'背'),color00FF00;
C6:=CROSS(长线,REF(长线,1));
C8:=BARSLAST(REF(C6,1));
DRAWTEXT(REF(C1,C8+1)>C1 AND REF(长线,C8+1)<中线 AND C6>0,长线,'背'),colorff00ff;
PARTLINE(长线,长线>REF(长线,1)),LINETHICK3,COLORFF00FF,LAYER1;
PARTLINE(中线,中线>REF(中线,1)),LINETHICK3,COLOR00FFFF,LAYER1;
PARTLINE(短线,短线>REF(短线,1)),LINETHICK3,COLOR00FF00,LAYER1;

20110928B.jpg

评分

参与人数 1等级分 +30 现金 +290 收起 理由
子路 + 30 + 290 原创内容

查看全部评分

回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

 楼主| 发表于 2011-9-28 20:52 | 显示全部楼层
原帖由 胡雪峰 于 2011-9-28 13:35 发表
龙兄论述非常精辟、值得借鉴!我欣赏!恭祝老兄十一节日快乐!


谢谢雪峰祝福!
希望节前红盘同乐!
回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2011-9-28 21:44 | 显示全部楼层
谁能改成通达信的,先谢谢了
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2011-10-10 09:05 | 显示全部楼层
谢谢龙三哥的精彩,支持
回复 支持 反对

使用道具 举报

新浪微博达人勋

六级海风会员

发表于 2011-11-22 13:13 | 显示全部楼层
原帖由 mzl19710317 于 2011-9-28 21:44 发表
谁能改成通达信的,先谢谢了

支持,福龙马来改改
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2011-11-23 10:32 | 显示全部楼层
改公式容易,大家要注意消化公式的含义
{MACD_SMA,通达信版}
JJ:=IF(C>200 OR VOL=0,(L+H+2*O+3*C)/7,AMOUNT/(VOL*100));
M1:=SMA(JJ,155,21);
M2:=SMA(JJ,455,21);
M3:=SMA(JJ,255,21);
M4:=SMA(JJ,655,21);
M5:=SMA(JJ,355,21);
M6:=SMA(JJ,855,21);
短:(M1-M2),COLORCCFFFF;
短1:EMA(短,5),COLOR58FF58;
中:M3-M4,COLOR00FFFF,LINETHICK2;
中1:EMA(中,7),COLORFF00FF;
MACD:=2*(中-中1);
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,3,1),COLOR1011FF;
STICKLINE(MACD>=0 AND MACD< REF(MACD,1),0,MACD,3,0),COLOR1088FF;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,3,1),COLORFFFFA0;
STICKLINE(MACD<0 AND MACD< REF(MACD,1),0,MACD,3,0),COLORFFCD00;
{FILLRGN(中,0,中>0 AND 中>中1 AND 中>REF(中,1),RGB(88,10,0)),LAYER7;
FILLRGN(中,0,中<0 AND 中<中 AND 中<REF(中,1),RGB(15,80,20)),LAYER7;}
IF(中<REF(中,1),中,DRAWNULL),COLORGREEN,LINETHICK2;
C1:=EMA(JJ,5);
C3:=BARSLAST(REF(CROSS(短,短1),1));
C4:=BARSLAST(REF(CROSS(短1,短1),1));
DRAWTEXT(REF(C1,C3+1)>C1 AND REF(短,C3+1)<短 AND CROSS(短,短1)>0,REF(短,1)*1.1,'背'),COLOR00FFFF;
DRAWTEXT(REF(C1,C4+1)<C1 AND REF(短,C4+1)>短 AND CROSS(短1,短)>0,REF(短,1)*1.2,'背'),COLOR00FF00;
长:M5-M6,COLORFFFF00,LINETHICK2;
长1:EMA(长,7),COLOR0022FF;
MR:IF(CROSS(中,中1) AND 短<0 AND REF(短,1)>REF(中,1) AND REF(中,1)>REF(长,1),MAX(HHV(短,120),-短),0),COLORAA00FF;
MC:IF(CROSS(中1,中) AND BARSLAST(短<=0)>9 AND REF(短,1)<REF(中,1) AND REF(中,1)<REF(长,1),MIN(LLV(短,120),-短),0),COLORFFFFFF;

评分

参与人数 1等级分 +29 现金 +291 收起 理由
子路 + 29 + 291 精品文章

查看全部评分

回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2011-11-23 10:34 | 显示全部楼层
{MACD_SUM通达信版}
DIFF:=EMA(CLOSE,12*2)-EMA(CLOSE,26*2);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
MACDZ1:SUM(MACD,0),COLORGREEN,LINETHICK4;
IF(MACDZ1>REF(MACDZ1,1),MACDZ1,DRAWNULL),COLORRED,LINETHICK4;
DIFF1:=EMA(CLOSE,12*3)-EMA(CLOSE,26*3);
DEA1:=EMA(DIFF1,11);
MACD1:=2*(DIFF1-DEA1);
MACDZ2:SUM(MACD1,0),COLORCYAN,LINETHICK2;
IF(MACDZ2>REF(MACDZ2,1),MACDZ2,DRAWNULL),COLORMAGENTA,LINETHICK2;
0,COLOR909090;

评分

参与人数 1等级分 +29 现金 +291 收起 理由
子路 + 29 + 291 精品文章

查看全部评分

回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2011-11-23 10:34 | 显示全部楼层
{MACD_3L:三线看盘,通达信版}
JJ0:=AMOUNT/(VOL*100);
JJ:=IF(C>JJ0*2 OR C<JJ0*2,(L+H+2*O+3*C)/7,JJ0);
短线:EMA(((EMA(C,5)-EMA(C,10))/EMA(C,10))*100,3),COLOR00AA00;
中线:EMA((EMA(C,10)-EMA(C,21))/EMA(C,21)*100,3),COLOR009999;
长线:EMA((EMA(C,21)-EMA(C,45))/EMA(C,45)*100,3),COLOR990099;
0,COLOR888888;
中线1:=EMA(中线,2);
C1:=EMA(JJ,7);
C2:=CROSS(中线1,REF(中线1,1));
C5:=CROSS(REF(中线1,1),中线1);
C3:=BARSLAST(REF(C2,1));
C4:=BARSLAST(REF(C5,1));
DRAWTEXT(REF(C1,C3+1)>C1 AND REF(中线1,C3+1)<中线 AND C2>0,中线,'背'),COLOR00FFFF;
DRAWTEXT(REF(C1,C4+1)<C1 AND REF(中线,C4+1)>中线 AND C5>0,中线,'背'),COLOR00FF00;
C6:=CROSS(长线,REF(长线,1));
C8:=BARSLAST(REF(C6,1));
DRAWTEXT(REF(C1,C8+1)>C1 AND REF(长线,C8+1)<中线 AND C6>0,长线,'背'),COLORFF00FF;
IF(长线>REF(长线,1),长线,DRAWNULL),LINETHICK3,COLORFF00FF;
IF(中线>REF(中线,1),中线,DRAWNULL),LINETHICK3,COLOR00FFFF;
IF(短线>REF(短线,1),短线,DRAWNULL),LINETHICK3,COLOR00FF00;

评分

参与人数 1等级分 +29 现金 +291 收起 理由
子路 + 29 + 291 精品文章

查看全部评分

回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

 楼主| 发表于 2011-11-23 13:03 | 显示全部楼层
感谢福龙马股友出手相助;
本人用惯了大智慧,也可能是较恋旧吧,
看到这么多人在用TDX,前期也搞了个看了看,
感觉差不多,似乎也没特别之处;
大概是没有用心去体会吧。
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

 楼主| 发表于 2011-11-23 13:20 | 显示全部楼层
顺便说明一下公式的用法:
MACD之一:
可重点关注短、中、长三线粘合,
在相对高位粘合时,要注意风险,因以后的下跌会有一定幅度;
同理,在相对低位时粘合,要把握机会,也会有一定升幅;
可观察前期的强势传媒类股。
其它例如背离、多头、空头排列等,也有参考作用。
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

 楼主| 发表于 2011-11-23 13:53 | 显示全部楼层
MACD之二 主要用于中长线;
MACD之三:
主要是想解决原 MACD 指标不能统一量化的问题,
其DIFF会因股价高低等原因,差别很大;
改动后,基本在相对固定的范围波动,
当然,随股性不同也会有点差别,但不大;
一般来说,当长线小于 -9或-10时,为严重超跌;
反之,大于9或10,风险来临了;
横盘整理时,视盘子大小、股性活跃度,也会有一定的运行区间,
这对操作,应有一定的帮助。
回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2012-1-1 01:51 | 显示全部楼层
祝版主新年快乐!
欣赏版主MACD 之三的主图,可否告知一.二!
非常感谢!
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

 楼主| 发表于 2012-1-2 23:44 | 显示全部楼层
原帖由 股指飞扬 于 2012-1-1 01:51 发表
祝版主新年快乐!
欣赏版主MACD 之三的主图,可否告知一.二!
非常感谢!


就是20天线,很简单的:
DZH_L2:
X2:MA(C,20),COLORAAAAAA;
压力:MA(REF(HHV(C,30),1),3),COLOR004444;
支撑:MA(REF(LLV(C,30),1),3),COLOR004400;
PARTLINE(压力,压力=REF(压力,1)),COLOR66DDFF;
PARTLINE(支撑,支撑=REF(支撑,1)),COLORAADD99;
PARTLINE(X2,X2>REF(X2,1)),COLORFF00FF,LINETHICK2;

TDX:
X2:MA(C,20),COLORAAAAAA;
压力:MA(REF(HHV(C,30),1),3),COLOR004444;
支撑:MA(REF(LLV(C,30),1),3),COLOR004400;
IF(压力=REF(压力,1),压力,DRAWNULL),COLOR66DDFF;
IF(支撑=REF(支撑,1),支撑,DRAWNULL),COLORAADD99;
IF(X2>REF(X2,1),X2,DRAWNULL),COLORFF00FF,LINETHICK2;
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2012-4-7 18:19 | 显示全部楼层
支持龙三哥的帖子,谢谢
回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2015-8-16 15:20 来自手机 | 显示全部楼层
老大辛苦了!
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2016-3-4 22:02 | 显示全部楼层
好东西, 谢谢老大
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2016-3-8 22:13 | 显示全部楼层
好东西 !!!!!
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2016-3-8 22:14 | 显示全部楼层
好东西 !!!!!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册会员 新浪微博登陆

本版积分规则

QQ|小黑屋|手机版|海风股票论坛 ( 闽ICP备05030991号-1 )|网站地图

GMT+8, 2017-10-17 14:03

 
快速回复 返回顶部 返回列表