请选择 进入手机版 | 继续访问电脑版
查看: 9673|回复: 27

答无锡,写了一个好玩的指标(通达信主图叠加)

[复制链接]

新浪微博达人勋

五级海风会员

发表于 2010-9-19 09:24 | 显示全部楼层 |阅读模式

马上注册海风会员,享受更多便捷服务!

您需要 登录 才可以下载或查看,没有帐号?注册会员 新浪微博登陆

x
按无锡的意思,划出金叉(或死叉)当天+第二天的高低点。
主图叠加。(非选股公式)  通达信可用,其他软件没测试。
M5:MA(C,5); M20:MA(C,20);
JC:=CROSS(M5,M20); SC:=CROSS(M20,M5);
JCD:=BARSLAST(JC); SCD:=BARSLAST(SC);
DRAWICON(JC,L*0.98,11); DRAWICON(SC,H*1.02,12);
CD:=MIN(JCD,SCD);
HH:=IF(CD>=2,MAX(REF(H,CD),REF(H,CD-1)),IF(CD=1,MAX(REF(H,1),H),H));
LL:=IF(CD>=2,MIN(REF(L,CD),REF(L,CD-1)),IF(CD=1,MIN(REF(L,1),L),L));
高线:HH,COLORLIRED; 低线: LL,COLORLIGREEN;

不知你要的是这个效果不?

Update:去掉上升下降,只保留横的平行线的代码 在4楼.












.

[ 本帖最后由 lx7999 于 2012-1-25 20:47 编辑 ]

评分

参与人数 2等级分 +80 现金 +800 收起 理由
黑夜鬼 + 30 + 300 我很赞同
木头 + 50 + 500 精品文章

查看全部评分

此为本站的广告赞助商,该站的任何商业行为,与本站无关!
回复

使用道具 举报

新浪微博达人勋

八级海风会员

发表于 2010-9-19 09:45 | 显示全部楼层
原帖由 coast 于 2010-9-19 09:24 发表
按无锡的意思,划出金叉(或死叉)当天+第二天的高低点。
主图叠加。(非选股公式)  通达信可用,其他软件没测试。
M5:MA(C,5); M20:MA(C,20);
JC:=CROSS(M5,M20); SC:=CROSS(M20,M5);
JCD:=BARSLAST(JC); SCD: ...



谢谢   就是这样的效果,另外高低点的划线能否去掉下降或上升的,只保留横的平行线














.

[ 本帖最后由 lx7999 于 2012-1-25 20:47 编辑 ]
回复 支持 反对

使用道具 举报

新浪微博达人勋

八级海风会员

发表于 2010-9-19 11:05 | 显示全部楼层
M5:MA(C,5);
M20:MA(C,20);
JC:=CROSS(M5,M20);
SC:=CROSS(M20,M5);
JCD:=BARSLAST(JC);
SCD:=BARSLAST(SC);
DRAWICON(JC,L*0.95,1);
DRAWICON(SC,H*1.05,2);
CD:=MIN(JCD,SCD);
HH:=IF(CD>=2,MAX(REF(H,CD),REF(H,CD-1)),IF(CD=1,MAX(REF(H,1),H),H));
LL:=IF(CD>=2,MIN(REF(L,CD),REF(L,CD-1)),IF(CD=1,MIN(REF(L,1),L),L));
高线:HH,COLORLIRED,LINETHICK4,POINTDOT;
低线:LL,COLORLIGREEN,LINETHICK4,POINTDOT;

比原来的好一点

评分

参与人数 1等级分 +30 现金 +290 收起 理由
子路 + 30 + 290 POINTDOT的妙用

查看全部评分

╭⌒╮HAPPY━┅~ ¤关注;分析;挖掘;捕捉。首次介入:封板;必涨。二次介入:必涨;异量竭;龙回头。三次介入:首战。四次介入:再战。
╱◥█◣ ╱◥█◣
︱田︱田︱︱田︱田︱
╬╬╬╬╬╬╬╬╬╬╬╬╬╬
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

 楼主| 发表于 2010-9-19 11:20 | 显示全部楼层

只保留横的平行线

M5:MA(C,5); M20:MA(C,20);
JC:=CROSS(M5,M20); SC:=CROSS(M20,M5);
JCD:=BARSLAST(JC); SCD:=BARSLAST(SC);
DRAWICON(JC,L*0.98,11); DRAWICON(SC,H*1.02,12);
CD:=MIN(JCD,SCD);
HH:=IF(CD>=2,MAX(REF(H,CD),REF(H,CD-1)),IF(CD=1,MAX(REF(H,1),H),H));
LL:=IF(CD>=2,MIN(REF(L,CD),REF(L,CD-1)),IF(CD=1,MIN(REF(L,1),L),L));
{ -------- 前面都不变,后面两句改成如下: -------- }
高线:IF(HH=REF(HH,1),HH,DRAWNULL),COLORLIRED;
低线:IF(LL=REF(LL,1),LL,DRAWNULL),COLORLIGREEN;

评分

参与人数 1等级分 +30 现金 +290 收起 理由
子路 + 30 + 290 精益求精

查看全部评分

回复 支持 反对

使用道具 举报

新浪微博达人勋

八级海风会员

发表于 2010-9-19 11:38 | 显示全部楼层
哈哈,越改越好了
╭⌒╮HAPPY━┅~ ¤关注;分析;挖掘;捕捉。首次介入:封板;必涨。二次介入:必涨;异量竭;龙回头。三次介入:首战。四次介入:再战。
╱◥█◣ ╱◥█◣
︱田︱田︱︱田︱田︱
╬╬╬╬╬╬╬╬╬╬╬╬╬╬
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2010-9-19 14:01 | 显示全部楼层
楼主编公式真是一个字高
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2010-9-19 19:47 | 显示全部楼层
呵呵,支持一下。不错的公式
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2010-9-21 01:46 | 显示全部楼层
楼主编公式真是一个字高
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2010-9-23 10:48 | 显示全部楼层
支持一下。不错的公式!
回复 支持 反对

使用道具 举报

新浪微博达人勋

超级版主

发表于 2010-9-23 10:57 | 显示全部楼层
支持
日系车的车祸率明显高于平均水平
回复 支持 反对

使用道具 举报

新浪微博达人勋

八级海风会员

发表于 2010-9-23 16:30 | 显示全部楼层
写了个止损线主图公式
------------------------
A0:=(L+H+C*2)/4;
度假:=EMA(A0,25)COLORYELLOW,LINETHICK1;
A2X:=(度假-REF(度假,1))/REF(度假,1)*100;
止损线:IF(A2X>=0,度假,DRAWNULL),COLORMAGENTA,LINETHICK2;

----------------------------------
但与N字交易系统区别大了点(看下图)如何改进????

[ 本帖最后由 无锡 于 2010-9-23 16:38 编辑 ]

评分

参与人数 1等级分 +30 现金 +290 收起 理由
子路 + 30 + 290 原创内容

查看全部评分

╭⌒╮HAPPY━┅~ ¤关注;分析;挖掘;捕捉。首次介入:封板;必涨。二次介入:必涨;异量竭;龙回头。三次介入:首战。四次介入:再战。
╱◥█◣ ╱◥█◣
︱田︱田︱︱田︱田︱
╬╬╬╬╬╬╬╬╬╬╬╬╬╬
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2010-9-23 20:11 | 显示全部楼层
------------------------
A0:=(L+H+C*2)/4;
度假:=EMA(A0,25)COLORYELLOW,LINETHICK1;
A2X:=(度假-REF(度假,1))/REF(度假,1)*100;
止损线:IF(A2X>=0,度假,DRAWN ... [/quote]
横的平行线没显示出来,无锡怎么弄得呀,教一下。谢谢。
回复 支持 反对

使用道具 举报

新浪微博达人勋

八级海风会员

发表于 2010-9-23 20:33 | 显示全部楼层
原帖由 新入股市 于 2010-9-23 20:11 发表
------------------------
A0:=(L+H+C*2)/4;
度假:=EMA(A0,25)COLORYELLOW,LINETHICK1;
A2X:=(度假-REF(度假,1))/REF(度假,1)*100;
止损线:IF(A2X>=0,度假,DRAWN ...

横的平行 ... [/quote]
A0:=(L+H+C*2)/4;

度假:=EMA(A0,25)COLORYELLOW,LINETHICK1;
A2X:=(度假-REF(度假,1))/REF(度假,1)*100;
止损线:IF(A2X>=0,度假,DRAWNULL),COLORMAGENTA,LINETHICK2;
止盈线:=IF(A2X>=0,度假*1.236,DRAWNULL),COLORYELLOW,LINETHICK1;


EMA5:=MA(CLOSE,5);
EMA20:=MA(CLOSE,20);

M5:=MA(C,5); M20:=MA(C,20);
JC:=CROSS(M5,M20); SC:=CROSS(M20,M5);
JCD:=BARSLAST(JC); SCD:=BARSLAST(SC);
DRAWICON(JC,L*0.98,1); DRAWICON(SC,H*1.02,2);
CD:=MIN(JCD,SCD);
HH:=IF(CD>=2,MAX(REF(H,CD),REF(H,CD-1)),IF(CD=1,MAX(REF(H,1),H),H));
LL:=IF(CD>=2,MIN(REF(L,CD),REF(L,CD-1)),IF(CD=1,MIN(REF(L,1),L),L));
{ -------- 前面都不变,后面两句改成如下: -------- }
高线:IF(HH=REF(HH,1),HH,DRAWNULL),COLORLIRED;
低线:IF(LL=REF(LL,1),LL,DRAWNULL),COLORLIGREEN;
╭⌒╮HAPPY━┅~ ¤关注;分析;挖掘;捕捉。首次介入:封板;必涨。二次介入:必涨;异量竭;龙回头。三次介入:首战。四次介入:再战。
╱◥█◣ ╱◥█◣
︱田︱田︱︱田︱田︱
╬╬╬╬╬╬╬╬╬╬╬╬╬╬
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2010-9-25 10:14 | 显示全部楼层
谢谢无锡兄:handshake
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

发表于 2010-9-28 14:24 | 显示全部楼层
谢谢无锡兄!!!!!!!!!!
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2010-9-29 12:52 | 显示全部楼层
楼主辛苦了 顶顶
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2010-10-25 10:16 | 显示全部楼层
不错,学习收下啦。
回复 支持 反对

使用道具 举报

新浪微博达人勋

初级海风会员

发表于 2010-10-26 18:47 | 显示全部楼层
楼主编公式真是一个字高
回复 支持 反对

使用道具 举报

新浪微博达人勋

初级海风会员

发表于 2010-10-29 20:33 | 显示全部楼层
就是这样的效果:victory: :victory:
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2010-10-31 21:09 | 显示全部楼层
学习下指标的编制思想
回复 支持 反对

使用道具 举报

新浪微博达人勋

初级海风会员

发表于 2010-11-6 12:35 | 显示全部楼层
找到自己的操作模式是最重要的,我要的不是一次二次的偶然获利,而是长期获利的理念,方法与技巧.
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2010-12-19 19:59 | 显示全部楼层
非常感谢你的指标分享,谢谢学习。
回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2015-8-17 16:05 来自手机 | 显示全部楼层
谢谢分享!
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2015-8-18 22:38 | 显示全部楼层
谢谢,学习了
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2016-3-4 22:01 | 显示全部楼层
好东西,学习了.
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2016-4-9 09:29 | 显示全部楼层
非常感谢你的指标分享,谢谢学习。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册会员 新浪微博登陆

本版积分规则

QQ|小黑屋|手机版|海风股票论坛 ( 闽ICP备05030991号-1 )|网站地图

GMT+8, 2017-11-21 20:09

 
快速回复 返回顶部 返回列表