请选择 进入手机版 | 继续访问电脑版
查看: 1957|回复: 3

智能选股

[复制链接]

新浪微博达人勋

五级海风会员

发表于 2010-4-21 22:56 | 显示全部楼层 |阅读模式

马上注册海风会员,享受更多便捷服务!

您需要 登录 才可以下载或查看,没有帐号?注册会员 新浪微博登陆

x
买量选股
VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));  
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));  
bb:=SUM(卖盘,6)+SUM(卖盘,5)+SUM(卖盘,4)+SUM(卖盘,3)+SUM(卖盘,2);
cg:=SUM(买盘,5)+SUM(买盘,4)+SUM(买盘,3)+SUM(买盘,2)+SUM(买盘,1);

aa:=sum(cg+bb,2)+买盘*5;
gg:=ref(sum(买盘,50),5) ;
a:=holdernum;
voh1:=(a-ref(a,5))/ref(a,5);
voh2:=(a-ref(a,10))/ref(a,10);
voh3:=(a-ref(a,20))/ref(a,20);
散:=voh1+voh2+ voh3;
COUNT( 散<-0.1 and 散<ref(散,1) and DYNAINFO(14)>1 and aa>0  and c>ma(c,5),1);




1.
ma5:ma(c,5);
ma10:=ma(c,10);

ma30:1*(ma(c,30)+ma(c,72))/2,COLORaaDD00,linethick2;

x1:=(C+L+H)/3;
x2:=EMA(x1,3);
x3:=EMA(x2,3);
DRAWICON(CROSS(X2,X3),L-0.1,10),colorYELLOW;
DRAWICON(CROSS(X3,X2),H+0.1,12),COLOR00FF33;
stickline(x2>=x3,low,high,2,1),colorred;
stickline(x2>=x3,close,open,6,1),colorred;
stickline(x2>=x3,close,open,6,1),colorred;
stickline(x2<x3,low,high,0.1,1),colorGREEN;
stickline(x2<x3,close,open,6,1),colorGREEN;
stickline(CROSS(X2,X3),open,close,6,0),colorYELLOW;
stickline(CROSS(X3,X2),open,close,6,0),COLOR00FF33;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF>9.8,O,C,6,0),COLORRED;
STICKLINE(ZDF<-9.8,O,C,6,0),COLOR00FF00;

  zig(2,5),COLORWHITE;
   VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));  
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));  
bb:=SUM(卖盘,6)+SUM(卖盘,5)+SUM(卖盘,4)+SUM(卖盘,3)+SUM(卖盘,2);
cg:=SUM(买盘,5)+SUM(买盘,4)+SUM(买盘,3)+SUM(买盘,2)+SUM(买盘,1);

aa:=sum(cg+bb,2)+买盘*5;
gg:=ref(sum(买盘,30),5) ;


  换手率1:=V/CAPITAL*100;
  RSV:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=1*(3*d-2*k);
hsl:=V/CAPITAL*100;
换手:=sum(hsl,5);

STICKLINE(  ZDF>4  and 换手>ref(换手,1) and  换手率1<20 and aa>ref(aa,1)*1 and  aa>gg ,o,c,6,0),COLORWHITE;
  STICKLINE(  ZDF>4 and 换手>ref(换手,1) and  换手率1<20 and  aa>ref(aa,1)*1 and  aa>gg  ,l,h,2,0),COLORWHITE;



2.
a:=holdernum;
voh1:=(a-ref(a,5))/ref(a,5);
voh2:=(a-ref(a,10))/ref(a,10);
voh3:=(a-ref(a,20))/ref(a,20);

0,POINTDOT,COLORaaDD00;
-0.05,POINTDOT;
-0.1,POINTDOT;
  散:voh1+voh2+ voh3 ;



if(散<0,散,0),COLOR00FF00,linethick1;
   if(散>0,0,散),colorff00ff;
if(散>-0.05,-0.05,散),colorYELLOW,linethick1;
if(散>-0.1,-0.1,散),colorred,linethick1;




3.

VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));  
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));  
bb:=SUM(卖盘,6)+SUM(卖盘,5)+SUM(卖盘,4)+SUM(卖盘,3)+SUM(卖盘,2);
cg:=SUM(买盘,5)+SUM(买盘,4)+SUM(买盘,3)+SUM(买盘,2)+SUM(买盘,1);
ZDF:=(C-REF(C,1))/REF(C,1)*100;
aa:=sum(cg+bb,2)+买盘*5;
cc:ref(sum(买盘,30),5);
mm:ref(sum(卖盘,30),5);
gg:=ref(sum(买盘,30),5) ;
dd:=(sum(aa,5))/10000;
RSV:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=1*(3*d-2*k);
TGLXS:=aa,COLORSTICK;
qs:=sum(aa-ref(aa,1),2)+买盘*5;
STICKLINE(TGLXS>0,0,TGLXS,4,1),COLOR7744ff;
STICKLINE(TGLXS<0,0,TGLXS,4,0),COLOR00FF00;
   STICKLINE(qs<0,0,qs,6,0),COLORGREEN;
  换手:V/CAPITAL*100,COLORWHITE;
   收益:FINANCE(33),colorff00ff;

盘:CAPITAL/1000000,COLORRED;
  STICKLINE( ZDF>3 and j<80 and aa>ref(aa,1) and TGLXS>cc and qs>0  and j>51    and k>j and dd>0,0,TGLXS,4,0),colorff00ff;
STICKLINE( ZDF>3 and j<80 and aa>ref(aa,1) and TGLXS>cc*2 and qs>0  and j>51   and k>j and dd>0,0,TGLXS,4,0),COLOR22FFFF;
买卖差:1*(买盘+卖盘)/10000,colorff00ff;



STICKLINE( ZDF>4 and   换手<20  and aa>ref(aa,1)*1 and  aa>gg ,0,TGLXS,5,0),COLORRED;.












.

[ 本帖最后由 lx7999 于 2012-1-25 22:04 编辑 ]

中信建投大智慧.rar

343.81 KB, 下载次数: 64

中信建投大智慧.rar

343.81 KB, 下载次数: 54

!
回复

使用道具 举报

新浪微博达人勋

五级海风会员

 楼主| 发表于 2010-4-21 22:58 | 显示全部楼层

换手

换手
0;
50,colorwhite;
aa:=V/CAPITAL*100;
换手:sum(aa,5),volstick;


1.
ma5:ma(c,5);
ma10:=ma(c,10);

ma30:1*(ma(c,30)+ma(c,72))/2,COLORaaDD00,linethick2;

x1:=(C+L+H)/3;
x2:=EMA(x1,3);
x3:=EMA(x2,3);
DRAWICON(CROSS(X2,X3),L-0.1,10),colorYELLOW;
DRAWICON(CROSS(X3,X2),H+0.1,12),COLOR00FF33;
stickline(x2>=x3,low,high,2,1),colorred;
stickline(x2>=x3,close,open,6,1),colorred;
stickline(x2>=x3,close,open,6,1),colorred;
stickline(x2<x3,low,high,0.1,1),colorGREEN;
stickline(x2<x3,close,open,6,1),colorGREEN;
stickline(CROSS(X2,X3),open,close,6,0),colorYELLOW;
stickline(CROSS(X3,X2),open,close,6,0),COLOR00FF33;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF>9.8,O,C,6,0),COLORRED;
STICKLINE(ZDF<-9.8,O,C,6,0),COLOR00FF00;

  zig(2,5),COLORWHITE;
   VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));  
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));  
bb:=SUM(卖盘,6)+SUM(卖盘,5)+SUM(卖盘,4)+SUM(卖盘,3)+SUM(卖盘,2);
cg:=SUM(买盘,5)+SUM(买盘,4)+SUM(买盘,3)+SUM(买盘,2)+SUM(买盘,1);

aa:=sum(cg+bb,2)+买盘*5;
gg:=ref(sum(买盘,50),5) ;


  换手率1:=V/CAPITAL*100;
  RSV:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=1*(3*d-2*k);
hsl:=V/CAPITAL*100;
换手:=sum(hsl,5);

STICKLINE(ZDF>4  and 换手>ref(换手,1) and  换手率1<20 and aa>ref(aa,1)*1 and  aa>gg ,o,c,6,0),COLORWHITE;
  STICKLINE(ZDF>4 and 换手>ref(换手,1) and  换手率1<20 and  aa>ref(aa,1)*1 and  aa>gg  ,l,h,2,0),COLORWHITE;



2.

VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));  
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));  
买卖差:=(买盘 + 卖盘);
x1:=(C+L+H)/3;
x2:=EMA(x1,3);
x3:=EMA(x2,3);
STICKLINE((x2<x3 and 买卖差 < 0),0,买卖差,5,0),,COLORGREEN;


JX1:=BARSSINCE(买盘);  
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);  
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);  
VAR30:=MA(VOL,JY2);
神比:=(买盘 / VAR30);  
鬼比:=(卖盘 / VAR30);  
VAR2:=(HIGH - LOW);  
VAR3:=ABS((OPEN - CLOSE));  
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));  
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);  
VAR6:=((VAR3 / VAR2) * VOL);  
VAR7:=((VAR4 / VAR2) * VOL);  
VAR8:=((VAR5 / VAR2) * VOL);  
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));  




多头:STICKLINE(x2>x3,0,VOL,5,1),COLOR0000FF;
空头:STICKLINE(x2<=x3,0,VOL,5,0),COLORGREEN;


STICKLINE((((x2>x3 and VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),0,VAR6,4,0),COLOR00FFFF;
STICKLINE((x2>x3 and 买卖差 > 0  ),买盘,0,2,0),COLOR0000FF;

成交:=vol,color10FFFF,linethick0;
主动买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),color10FFFF,linethick0;
主动卖盘:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),color10FFFF,linethick0;

净买盘:=主动买盘+主动卖盘,pointdot,coloryellow;

stickline(净买盘>0 and x2>x3,0,净买盘,4,0),COLOR22FFFF;

  买卖差1:1*(买盘+卖盘)/10000,colorff00ff;



3.
VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));  
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));  
bb:=SUM(卖盘,6)+SUM(卖盘,5)+SUM(卖盘,4)+SUM(卖盘,3)+SUM(卖盘,2);
cg:=SUM(买盘,5)+SUM(买盘,4)+SUM(买盘,3)+SUM(买盘,2)+SUM(买盘,1);
ZDF:=(C-REF(C,1))/REF(C,1)*100;
aa:=sum(cg+bb,2)+买盘*5;
cc:ref(sum(买盘,50),5);
mm:ref(sum(卖盘,50),5);
gg:=ref(sum(买盘,50),5) ;
dd:=(sum(aa,5))/10000;
RSV:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=1*(3*d-2*k);
TGLXS:=aa,COLORSTICK;
qs:=sum(aa-ref(aa,1),2)+买盘*5;
STICKLINE(TGLXS>0,0,TGLXS,4,1),COLOR7744ff;
STICKLINE(TGLXS<0,0,TGLXS,4,0),COLOR00FF00;
   STICKLINE(qs<0,0,qs,6,0),COLORGREEN;
  换手:V/CAPITAL*100,COLORWHITE;
   收益:FINANCE(33),colorff00ff;

盘:CAPITAL/1000000,COLORRED;
  STICKLINE( ZDF>3 and j<80 and aa>ref(aa,1) and TGLXS>cc and qs>0  and j>51    and k>j and dd>0,0,TGLXS,4,0),colorff00ff;
STICKLINE( ZDF>3 and j<80 and aa>ref(aa,1) and TGLXS>cc*2 and qs>0  and j>51   and k>j and dd>0,0,TGLXS,4,0),COLOR22FFFF;
买卖差:=1*(买盘+卖盘)/10000,colorff00ff;

   hsl:=V/CAPITAL*100;
手:=sum(hsl,5);

STICKLINE( ZDF>4 and 手>ref(手,1) and  换手<20  and aa>ref(aa,1)*1 and  aa>gg ,0,TGLXS,5,0),COLORRED;














.

[ 本帖最后由 lx7999 于 2012-1-25 22:04 编辑 ]
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

发表于 2010-4-21 23:04 | 显示全部楼层
发过了,干吗又发一遍?
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2015-8-19 06:43 来自手机 | 显示全部楼层
免费分析软件可以使用吗?
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册会员 新浪微博登陆

本版积分规则

QQ|小黑屋|手机版|海风股票论坛 ( 闽ICP备05030991号-1 )|网站地图

GMT+8, 2017-8-19 09:45

 
快速回复 返回顶部 返回列表