请选择 进入手机版 | 继续访问电脑版
查看: 20469|回复: 50

选股公式:MACD低位金叉和倾家荡产买

[复制链接]

新浪微博达人勋

荣誉会员

发表于 2010-1-2 15:26 | 显示全部楼层 |阅读模式

马上注册海风会员,享受更多便捷服务!

您需要 登录 才可以下载或查看,没有帐号?注册会员 新浪微博登陆

x
有股友问这个问题:

以下指标没有选股公式,能否帮我做一个选股公式
1.MACD低位金叉的选股公式,以下是该公式的源码:
DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIFF,9),COLORFFFF00;
MACD:(DIFF-DEA)*2;

STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORRED;
STICKLINE(MACD>=0 AND MACD<=REF(MACD,1),0,MACD,1,0),COLORGREEN;
STICKLINE(MACD<=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORFF00FF;
STICKLINE(MACD<=0 AND MACD<=REF(MACD,1),0,MACD,1,0),COLOR00FFFF;

多转空:=((((LLV(MACD,4)>0) AND (MACD<REF(MACD,1))) AND (REF(MACD,1)>REF(MACD,2))) AND (REF(MACD,2)>REF(MACD,3)));
空转多:=((((HHV(MACD,4)<0) AND (MACD>REF(MACD,1))) AND (REF(MACD,1)<REF(MACD,2))) AND (REF(MACD,2)<REF(MACD,3)));
DRAWICON(多转空,MACD,2);
DRAWICON(空转多,MACD,1);
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
DRAWTEXT(低位金叉,DEA,'  低位金叉'),COLORFF00FF;
{STICKLINE(低位金叉,0,0.3,8,0),COLORYELLOW;
DRAWICON(低位金叉,0.3,1)}JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.2,2,0),COLORFF00FF;
DRAWTEXT(二次金叉,DEA*1.06,'二次金叉'),COLORRED;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
{STICKLINE(底背离,0.5,0.8,2,0),COLORRED}DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK3;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORBLUE,LINETHICK3;

2.倾家荡产的选股公式,以下是源码:

倾家荡产买(副图)源码:
{n: 1,  100,  3}
Var1:=MA(HHV(HIGH,485),17);
Var2:=MA(HHV(HIGH,222),17);
Var3:=MA(HHV(HIGH,96),17);
Var4:=MA(LLV(LOW,485),17);
Var5:=MA(LLV(LOW,222),17);
Var6:=MA(LLV(LOW,96),17);
Var7:=MA((Var4*0.96+Var5*0.96+Var6*0.96+Var1*0.558+Var2*0.558+Var3*0.558)/6,17);
Var8:=MA((Var4*1.25+Var5*1.23+Var6*1.2+Var1*0.55+Var2*0.55+Var3*0.65)/6,17);
Var9:=MA((Var4*1.3+Var5*1.3+Var6*1.3+Var1*0.68+Var2*0.68+Var3*0.68)/6,17);
VarA:=MA((Var7*3+Var8*2+Var9)/6*1.738,17);
VarB:=IF(DATE<=1050531,VarA,VarA*DAY);
VarC:=LOW;
VarD:=REF(LOW,1);
VarE:=SMA(ABS(VarC-VarD),3,1)/SMA(MAX(VarC-VarD,0),N,1)*100;
VarF:=MA(IF(CLOSE*1.35<=VarB,VarE*10,VarE/10),N);
Var10:=LLV(LOW,30);
Var11:=HHV(VarF,30);
Var12:=1990831;
绝佳买点:=IF(DATE<=Var12,MA(IF(LOW<=Var10,(VarF+Var11*2)/2,0),N),100000000);
I:=IF(CLOSE<REF(CLOSE,1),VOL/CAPITAL*10053,0);
骤雨初晴:= ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);
短线买:if(绝佳买点>500 and 绝佳买点>2500,1,0),coloryellow,LINETHICK1;
中线买:if(绝佳买点>10000 and 绝佳买点>20000,2,0),colorff00ff,LINETHICK2;
倾家荡产买:if(绝佳买点>30000 and 绝佳买点>30000,3,0),colorred,LINETHICK3;.












.

[ 本帖最后由 lx7999 于 2012-1-25 22:01 编辑 ]

评分

参与人数 1等级分 +30 现金 +300 收起 理由
黑夜鬼 + 30 + 300 精品指标。10年的东东,到现在还是精品。

查看全部评分

海风机构报告会员!
回复

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2010-1-2 15:54 | 显示全部楼层
以后大家有什么问题的话,可以发帖问。毕竟人多力量大,而且论坛的目的就在于交流。谢谢!

1.MACD低位金叉的选股公式:
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
低位金叉:CROSS(DIFF,DEA) AND DIFF<-0.1;














.

[ 本帖最后由 lx7999 于 2012-1-25 22:02 编辑 ]
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2010-1-2 15:55 | 显示全部楼层
2.倾家荡产买的选股公式
{n: 1,  100,  3}
VAR1:=MA(HHV(HIGH,485),17);
VAR2:=MA(HHV(HIGH,222),17);
VAR3:=MA(HHV(HIGH,96),17);
VAR4:=MA(LLV(LOW,485),17);
VAR5:=MA(LLV(LOW,222),17);
VAR6:=MA(LLV(LOW,96),17);
VAR7:=MA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,17);
VAR8:=MA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,17);
VAR9:=MA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,17);
VARA:=MA((VAR7*3+VAR8*2+VAR9)/6*1.738,17);
VARB:=IF(DATE<=1050531,VARA,VARA*DAY);
VARC:=LOW;
VARD:=REF(LOW,1);
VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),N,1)*100;
VARF:=MA(IF(CLOSE*1.35<=VARB,VARE*10,VARE/10),N);
VAR10:=LLV(LOW,30);
VAR11:=HHV(VARF,30);
VAR12:=1990831;
绝佳买点:=IF(DATE<=VAR12,MA(IF(LOW<=VAR10,(VARF+VAR11*2)/2,0),N),100000000);
倾家荡产买:绝佳买点>30000;

[ 本帖最后由 子路 于 2010-1-2 21:58 编辑 ]
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

发表于 2010-1-2 16:42 | 显示全部楼层
子路辛苦了!:handshake
股市没有对与错,只有输与赢
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2010-1-2 19:13 | 显示全部楼层
版主辛苦了虎年发发:victory:
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

发表于 2010-1-2 20:42 | 显示全部楼层
当前公式 : 倾家荡产买的 (条件选股公式)  
错误句 :
VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),N,1)*100
详细信息 : 未知字符串 N
错误起始位置 : 571 ; 长度: 1

子路辛苦你看看上面哪里错了?谢谢 。
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2010-1-2 21:59 | 显示全部楼层
原帖由 三伏 于 2010-1-2 20:42 发表
当前公式 : 倾家荡产买的 (条件选股公式)  
错误句 :
VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),N,1)*100
详细信息 : 未知字符串 N
错误起始位置 : 571 ; 长度: 1

子路辛苦你看看上面哪里错了? ...

参数N没有设置,按这句设置下:
{n: 1,  100,  3}
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2010-1-2 22:13 | 显示全部楼层
之路 新年好 刚用MACD低位金叉的选股公式,选出太多了,还要观察看看。
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

发表于 2010-1-3 10:06 | 显示全部楼层
谢谢子路,元旦加班,辛苦了,祝2010年财源广进!
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2010-1-3 11:27 | 显示全部楼层
谢谢版主!这些公式在炒股软件上都可以用吗?
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

发表于 2010-1-3 12:56 | 显示全部楼层
我不会用(:0046:) 要是有现成的股票告诉我就好了(:0028:)
趁你病,要你命!
回复 支持 反对

使用道具 举报

新浪微博达人勋

六级海风会员

发表于 2010-1-3 19:00 | 显示全部楼层
谢谢子路版主!
新年快乐!!

大家一起发大财!!

[ 本帖最后由 万点直击 于 2010-1-3 19:02 编辑 ]
回复 支持 反对

使用道具 举报

新浪微博达人勋

六级海风会员

发表于 2010-1-3 20:39 | 显示全部楼层
那个倾家荡产买好像有未来函数?
第21行包含未来函数:capital
第22行包含未来函数:winner
目标:小赚
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2010-1-3 21:13 | 显示全部楼层
新年快乐!!
大家发财!!
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2010-1-3 21:28 | 显示全部楼层
子路老师新年好!
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2010-1-3 23:10 | 显示全部楼层
原帖由 松涛 于 2010-1-3 12:56 发表
我不会用(:0046:) 要是有现成的股票告诉我就好了(:0028:)

问我要这公式的人说是要开帖的,到时候列出选股结果,随便你挑。(:0001:)
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

发表于 2010-1-5 17:46 | 显示全部楼层
请高手指教MACD低位金叉的选股公式:
提示这个COLORFFFF00没有定义标识符,不能用.我的软件是老的大智慧.
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2010-1-5 18:21 | 显示全部楼层
原帖由 九峰山 于 2010-1-5 17:46 发表
请高手指教MACD低位金叉的选股公式:
提示这个COLORFFFF00没有定义标识符,不能用.我的软件是老的大智慧.

2楼改过了,这个颜色设定在选股公式中是不必要的,上次忘记去掉了。(:0005:)
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2010-1-5 19:42 | 显示全部楼层
子路版主,好像有未来函数哦
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2010-1-6 01:39 | 显示全部楼层
倾家荡产买指标我没怎么用过,不知道效果。
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2010-1-6 08:30 | 显示全部楼层
好像我的大智慧不能用、、、
回复 支持 反对

使用道具 举报

新浪微博达人勋

六级海风会员

发表于 2010-1-6 19:57 | 显示全部楼层
版主辛苦了   好RP呀   恭喜发财
股票好不好 买了才知道
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

发表于 2010-1-6 21:40 | 显示全部楼层
君子务本,本立而道生
知行合一
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2010-1-6 22:42 | 显示全部楼层
倾家荡产买是tdx的?大智慧中显示有未定义的N :Q
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2010-1-7 16:38 | 显示全部楼层
原帖由 globe 于 2010-1-6 22:42 发表
倾家荡产买是tdx的?大智慧中显示有未定义的N :Q

我的大智慧也不能用:P
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2010-1-7 16:44 | 显示全部楼层
原帖由 globe 于 2010-1-6 22:42 发表
倾家荡产买是tdx的?大智慧中显示有未定义的N :Q

看7楼。(:0014:)
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

六级海风会员

发表于 2010-1-8 09:29 | 显示全部楼层
倾家荡产副图 (DZH1 经典版本 5.60)
参数名  最小   最大  缺省
N              1            100     3

Var1:=MA(HHV(HIGH,485),17);
Var2:=MA(HHV(HIGH,222),17);
Var3:=MA(HHV(HIGH,96),17);
Var4:=MA(LLV(LOW,485),17);
Var5:=MA(LLV(LOW,222),17);
Var6:=MA(LLV(LOW,96),17);
Var7:=MA((Var4*0.96+Var5*0.96+Var6*0.96+Var1*0.558+Var2*0.558+Var3*0.558)/6,17);
Var8:=MA((Var4*1.25+Var5*1.23+Var6*1.2+Var1*0.55+Var2*0.55+Var3*0.65)/6,17);
Var9:=MA((Var4*1.3+Var5*1.3+Var6*1.3+Var1*0.68+Var2*0.68+Var3*0.68)/6,17);
VarA:=MA((Var7*3+Var8*2+Var9)/6*1.738,17);
VarB:=IF(DATE<=1050531,VarA,VarA*DAY);
VarC:=LOW;
VarD:=REF(LOW,1);
VarE:=SMA(ABS(VarC-VarD),3,1)/SMA(MAX(VarC-VarD,0),N,1)*100;
VarF:=MA(IF(CLOSE*1.35<=VarB,VarE*10,VarE/10),N);
Var10:=LLV(LOW,30);
Var11:=HHV(VarF,30);
Var12:=1990831;
绝佳买点:=IF(DATE<=Var12,MA(IF(LOW<=Var10,(VarF+Var11*2)/2,0),N),100000000);
I:=IF(CLOSE<REF(CLOSE,1),VOL/CAPITAL*10053,0);
骤雨初晴:= ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);
短线买:if(绝佳买点>500 and 绝佳买点>2500,1,0),coloryellow,LINETHICK1;
中线买:if(绝佳买点>10000 and 绝佳买点>20000,2,0),colorff00ff,LINETHICK2;
倾家荡产买:if(绝佳买点>30000 and 绝佳买点>30000,3,0),colorred,LINETHICK3
股票好不好 买了才知道
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2010-1-9 11:54 | 显示全部楼层
原帖由 子路 于 2010-1-7 16:44 发表

看7楼。(:0014:)

依然报错,把n改成N也是一样。。。“未定义的变量N”,有其他用新一代大智慧能用的朋友吗?
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2010-1-9 14:15 | 显示全部楼层
原帖由 globe 于 2010-1-9 11:54 发表

依然报错,把n改成N也是一样。。。“未定义的变量N”,有其他用新一代大智慧能用的朋友吗?

你把N改成3吧。(:0002:)
如果还是不行,或者你要知道为什么出错,把你导入公式的画面完整地贴上来,我看看原因。
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2010-1-10 11:02 | 显示全部楼层
发生错误的行数已经圈出,麻烦子路了。
倾家荡产.JPG
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册会员 新浪微博登陆

本版积分规则

QQ|小黑屋|手机版|海风股票论坛 ( 闽ICP备05030991号-1 )|网站地图

GMT+8, 2017-12-13 09:51

 
快速回复 返回顶部 返回列表