请选择 进入手机版 | 继续访问电脑版
楼主: 子路

曾经在小屋天空中飘荡的公式

[复制链接]

新浪微博达人勋

荣誉会员

 楼主| 发表于 2009-12-9 13:10 | 显示全部楼层
原帖由 wzwxy 于 2009-12-9 12:49 发表
秘密买点的机构建仓,它是依据什么得出来的结论?

就是先计算“趋势”:
趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
翻译过来就是:
趋势赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均

然后判断“趋势<5”,则给出机构建仓信号。

问题是,这个计算式我看不懂是什么,或者和哪个常用的指标类似。(:0002:)

评分

参与人数 1等级分 +50 现金 +500 收起 理由
wzwxy + 50 + 500 谢谢

查看全部评分

股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
黄金广告位招租
回复 支持 反对

使用道具 举报

新浪微博达人勋

八级海风会员

发表于 2009-12-9 13:13 | 显示全部楼层
最好加上公式的解释、用法和用户评价,那就完美了。(:0038:)
不想做庄家的机构不是好散户!!!
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2009-12-9 13:18 | 显示全部楼层
原帖由 子路 于 2009-12-9 13:10 发表

就是先计算“趋势”:
趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
翻译过来就是:
趋势赋值:3*(收盘价- ...

秘密买点公式大智慧用不了,是其他股票软件吗?
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2009-12-9 13:27 | 显示全部楼层
感谢子路做出这个总结,秘密买点参考性较高,一直使用。:)
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2009-12-9 13:46 | 显示全部楼层
原帖由 哨子 于 2009-12-9 13:18 发表

秘密买点公式大智慧用不了,是其他股票软件吗?

别人的大智慧可以用,我的通达信也行。
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2009-12-9 13:49 | 显示全部楼层
原帖由 股隐 于 2009-12-9 13:13 发表
最好加上公式的解释、用法和用户评价,那就完美了。(:0038:)

很多本来就没有用法的介绍,只是看见有信号出现,总是好的。至于用户评价,欢迎大家在这里交流。
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2009-12-9 16:12 | 显示全部楼层
原帖由 子路 于 2009-12-9 13:46 发表

别人的大智慧可以用,我的通达信也行。

可以了,刚才操作失误。
多谢,正在研究

[ 本帖最后由 哨子 于 2009-12-9 16:22 编辑 ]
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2009-12-9 16:20 | 显示全部楼层
原帖由 子路 于 2009-12-9 13:49 发表

很多本来就没有用法的介绍,只是看见有信号出现,总是好的。至于用户评价,欢迎大家在这里交流。

秘密买点用的人比较多,我复盘了一下,选了些我比较熟悉的医药股,感觉买点比较准。
即使是在去年大熊市,还是可以做到盈利的。
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2009-12-10 09:13 | 显示全部楼层
楼主:给你提个建议,能否将每个公式配上图片,坛友们一目了然。
另有个副图公式的图片,不知你是否有或者知道是何原理、函数。谢谢!
20091108_8479b54354a35a4ff382HeGOw0QahzAd.jpg


20091108_41db60e101de82e64c9f5M44qqz5jh4U.jpg



20091108_c700e3ab90654c21b45550Z52eiI4i7S.jpg

[ 本帖最后由 遨游九天 于 2009-12-10 09:19 编辑 ]

评分

参与人数 1等级分 +50 现金 +500 收起 理由
wzwxy + 50 + 500 我很赞同

查看全部评分

回复 支持 反对

使用道具 举报

新浪微博达人勋

超级版主

发表于 2009-12-10 09:42 | 显示全部楼层
太阳泪发的
{杠上开花  N=8}
A1:=REF(H,N)=HHV(H,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);{高点}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);
DRAWLINE(D1,H,S11,H,1),COLORBLUE;
A2:=REF(L,N)=LLV(L,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);{低点}
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1);
DRAWLINE(D2,L,U11,L,1),COLORBLUE;
M:=INTPART(3*N/5);
A12:=REF(H,M)=HHV(H,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);{高点}
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);
DRAWLINE(D12,H,S112,H,1),COLORRED;
A22:=REF(L,M)=LLV(L,2*M+1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M+1);
D22:=FILTER(C22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1);
DRAWLINE(D22,L,U112,L,1),COLORRED;
VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2222:=CROSS(VAR1111,0.9);
VAR3333:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR4444:=CROSS(VAR3333,0.9);
压力:= REF(HIGH,BARSLAST(VAR2222));
STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2222)),REF(HIGH,BARSLAST(VAR2222)),0.5,1),COLOREA91B5,LINETHICK3;
支撑:= REF(LOW,BARSLAST(VAR4444));
STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4444)),REF(LOW,BARSLAST(VAR4444)),0.5,1),COLOR00B4FF,LINETHICK3;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RRRSV:=SMA(下档线,3,1);
KKK:=SMA(RRRSV,3,1);
DDD:=((3 * RRRSV) - (2 * KKK));
JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) - (2 * K24));
压力2:=IF(CROSS(D24,DDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDD)))),COLORFFFFFF;
压力位:=IF(ISLASTBAR,压力2,DRAWNULL);
STICKLINE(ISLASTBAR ,压力位,压力位,120,0),LINETHICK4,COLORFFFFFF;
底部:=LLV(HIGH,30),COLOR00FF00;
底部位:=IF(ISLASTBAR,底部,DRAWNULL);
STICKLINE(ISLASTBAR ,底部位,底部位,100,0),LINETHICK4,COLOR00FF00;



AA05:=MA(C,5),COLOR0099CC;
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:EMA((速度5-REF(速度5,1)),3),NODRAW;
AA10:=MA(C,10);
AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
VAR11:=(AA20-AA30)>REF((AA20-AA30),1)
AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR22:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND
AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND
CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND
AA05>REF(AA05,1)  AND 三拾日乖离率>REF(三拾日乖离率,1) AND
AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1)  ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND
AA05<REF(AA05,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND
AA10<REF(AA10,1),10);
DRAWICON(加仓 ,LOW*0.99,23);
DRAWICON(清仓 ,HIGH*1.01,15);
DRAWICON(强势狙击 ,LOW*0.99,13);
TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,6));
差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
短线:VAR1,COLORWHITE;
中线:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6, DRAWNULL),COLORGREEN;
TJ1:= CCI1>差值4;
立桩量:=FILTER(TJ1,0);
TJ2:=IF(BARSLAST(立桩量)=1 ,1,IF(BARSLAST(立桩量)=2 ,1,
IF(BARSLAST(立桩量)=3 ,1,0)));
成立1:=TJ2;
条件成立1:=FILTER(成立1,5);
TJ11:= CCI1<-差值4 ;
立桩量2:=FILTER(TJ11,0);
TJ22:=IF(BARSLAST(立桩量2)=1 AND CLOSE>REF(HIGH,1),1,
IF(BARSLAST(立桩量2)=2 AND CLOSE>REF(HIGH,2),1,
IF(BARSLAST(立桩量2)=3 AND CLOSE>REF(HIGH,3),1,0)));
成立2:=TJ22;
条件成立2:=FILTER(成立2,5);
TJ111:=(ABS(CCI1)>CCI AND ABS( 差值1)> ABS(差值5))
OR (VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1);
立桩量3:=FILTER(TJ111,5);
TJ222:=IF(BARSLAST(立桩量3)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破3:=TJ222=1;
STICKLINE(CLOSE AND 下跌!= VAR6,REF(HIGH,BARSLAST(立桩量3)),
REF(HIGH,BARSLAST(立桩量3)),10,1),COLORCYAN;
STICKLINE(CLOSE AND 下跌!= VAR6,REF(LOW,BARSLAST(立桩量3)),
REF(LOW,BARSLAST(立桩量3)),10,1),COLORYELLOW;
TJ3:=IF(BARSLAST(立桩量3)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破3;
条件成立:=FILTER(成立,5);
TJ31:=(VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1);
TJ32:=FILTER(TJ31,1);
IF(条件成立 AND 下跌!= VAR6 AND AA30>=REF(AA30,1),H*1.03,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF33FF;
IF(条件成立 AND 下跌!= VAR6 AND AA30>=REF(AA30,1),H*1.03,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;

STICKLINE(C>=O,L,H,0,0),COLORRED;
STICKLINE(C<O,L,H,0,0),COLORFFFF00;
STICKLINE(C>O,C,O,3.2,0),COLORRED;
STICKLINE(1,C,O,2.8,0),COLOR454500;
STICKLINE(1,C,O,2,0),COLOR555500;
STICKLINE(1,C,O,1.5,0),COLOR656500;
STICKLINE(1,C,O,1,0),COLOR757500;
STICKLINE(1,C,O,0.5,0),COLOR858500;
STICKLINE(立桩量,C,O,2.8,0),COLOR000045;
STICKLINE(立桩量,C,O,2.8,0),COLOR000065;
STICKLINE(立桩量,C,O,2,0),COLOR000085;
STICKLINE(立桩量,C,O,1.5,0),COLOR0000A5;
STICKLINE(立桩量,C,O,1,0),COLOR0000C5;
STICKLINE(立桩量,C,O,0.5,0),COLOR0000E5;
DRAWICON(条件成立1,REF(HIGH,BARSLAST(立桩量3)),12);
DRAWICON(条件成立2,REF(LOW,BARSLAST(立桩量3)),11);
1.jpg

回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2009-12-10 11:06 | 显示全部楼层
原帖由 遨游九天 于 2009-12-10 09:13 发表
楼主:给你提个建议,能否将每个公式配上图片,坛友们一目了然。
另有个副图公式的图片,不知你是否有或者知道是何原理、函数。谢谢!

好的,谢谢你的建议,我有空就补图
你这个副图公式我没见过,麻烦有没有从头到尾,从左到右,所有的画面都全的,什么都不要漏,我好给它相个面。(:0014:)

[ 本帖最后由 子路 于 2009-12-10 11:08 编辑 ]
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2009-12-10 16:10 | 显示全部楼层
原帖由 子路 于 2009-12-7 13:12 发表
这是雨后春笋老师给的公式
副图公式:老张建仓

VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6: ...


回子路:

第11行有错误: VAR9>REF,应改为VAR9<REF
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2009-12-10 16:56 | 显示全部楼层
40楼的杠上开花有未来,慎用!!!!:(

2009-12-10_165323.gif
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2009-12-10 17:30 | 显示全部楼层
:lol

2009-12-10_172824.gif
回复 支持 反对

使用道具 举报

新浪微博达人勋

八级海风会员

发表于 2009-12-10 17:32 | 显示全部楼层
原帖由 wzwxy 于 2009-12-9 12:49 发表
秘密买点的机构建仓,它是依据什么得出来的结论?


原理是低位条件限制。。。以前搞过类似的。。呵呵我这个比他准

[ 本帖最后由 林夕 于 2009-12-10 17:33 编辑 ]
截图09.png

评分

参与人数 1等级分 +50 现金 +500 收起 理由
wzwxy + 50 + 500 原创内容

查看全部评分

譬彼病目,见空中花及第二月。空实无花,病者妄执,由妄执故,非唯惑此虚空自性,亦复迷彼实花生处,由此妄有轮转生死,
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2009-12-10 17:34 | 显示全部楼层
原帖由 短线一戈 于 2009-12-10 16:10 发表


回子路:

第11行有错误: VAR9>REF,应改为VAR9

说实话,这个公式在我通达信里,有好几根线趴在地上,我也没找出原因。这么长的公式看着真累,而且有些可能是大智慧的语法,我实在是头晕。(:0005:)
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

超级版主

发表于 2009-12-10 17:35 | 显示全部楼层
秘密买点与老纳的老鼠仓结合共振的力度比较大。
002034.GIF

回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2009-12-10 17:40 | 显示全部楼层
原帖由 林夕 于 2009-12-10 17:32 发表

原理是低位条件限制。。。以前搞过类似的。。呵呵我这个比他准

你的公式给出的信号比秘密买点多一些。如果在某个低位秘密买点信号后,短期内再下探这个位置,秘密买点是没信号的。这我已经发现在很多个股上是这样,但你的公式后面仍旧给出了信号。
你的公式在这里有发过没有?能不能让大家参考下?先谢了!(:0001:)
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

八级海风会员

发表于 2009-12-10 17:55 | 显示全部楼层
原帖由 子路 于 2009-12-10 17:40 发表

你的公式给出的信号比秘密买点多一些。如果在某个低位秘密买点信号后,短期内再下探这个位置,秘密买点是没信号的。这我已经发现在很多个股上是这样,但你的公式后面仍旧给出了信号。
你的公式在这里有发过没有? ...

原理在这些常用语句里。。可以自己发挥。。我已不搞这类公式了。。。给你鱼竿。。不给<。)#)))≦
1)今收盘对于N日内最低收盘价的涨幅(%)(c-llv(c,n))/llv(c,n)*100;
2)今收盘价对于N日最高收盘价的跌幅(%)(HHV(C,N)-C)/HHV(C,N)*100;
3)股价在过去N日内运行空间的相对位置 (C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;

评分

参与人数 1等级分 +50 现金 +500 收起 理由
wzwxy + 50 + 500 我很赞同

查看全部评分

譬彼病目,见空中花及第二月。空实无花,病者妄执,由妄执故,非唯惑此虚空自性,亦复迷彼实花生处,由此妄有轮转生死,
回复 支持 反对

使用道具 举报

新浪微博达人勋

荣誉会员

 楼主| 发表于 2009-12-10 18:04 | 显示全部楼层
原帖由 林夕 于 2009-12-10 17:55 发表

原理在这些常用语句里。。可以自己发挥。。我已不搞这类公式了。。。给你鱼竿。。不给

谢谢!我晚上读一下,看能不能消化。(:0001:)
股市总是重复历史,但是从来不会一模一样地重复。
Lie to me
不会看股,不会操作的是凡人。会看股,不会操作的是妖怪。会看股,又会操作的是神仙。我正在努力从凡人向妖怪挺进,所以只能算个人妖。
回复 支持 反对

使用道具 举报

新浪微博达人勋

超级版主

发表于 2009-12-10 19:29 | 显示全部楼层
我从老张那里拷贝的也是不可以。:(

Var2:=REF(LOW,1);
Var3:=SMA(ABS(LOW-Var2),13,1)/SMA(MAX(LOW-Var2,0),13,1)*100;
Var4:=EMA(IF(CLOSE*1.2,Var3*13,Var3/13),13);
Var5:=LLV(LOW,34);
Var6:=HHV(Var4,34);
Var7:=IF(LLV(LOW,56),1,0);
Var8:=EMA(IF(LOW<=Var5,(Var4+Var6*2)/2,0),3)/618*Var7;
Var9:=EMA(CLOSE,5);
Var10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
A:IF(Var9>REF(Var9,1),Var9,0),colorBLUE,linethick0;
B:IF(Var9<REF(Var9,1),Var9,0),color1010FF,linethick0;
STICKLINE(Var8>REF(Var8,1),0,Var8,4,1),color10FFFF;
进:IF(Var8>REF(Var8,1),Var8*8,0),color10FFFF,linethick0;
STICKLINE(Var8<REF(Var8,1),0,Var8,4,1),colorFFF810;
洗:IF(Var8<REF(Var8,1),Var8*10,0),colorFFF810,linethick0;
持:(LOW*5),colorFF10FF,linethick0;
差:Var10,colorFF7676;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
STICKLINE(XL3,0,Var8*3,4,0),Color006EFF;
DRAWTEXT(XL3,Var8*2,'买'),ColorRED;
↑买: DRAWICON(XL3,0,4),COLORRED;
R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(R,3,1),COLORRED;
M:SMA(K,3,1),coloryellow;
PARTLINE(K,K<M),colorcyan;
a:=K>=ref(K,1) and c<=ref(c,1)  and l=llv(l,9) ;
drawicon(a,K,1),COLORRED;
b:=K<=ref(K,1) and c>=ref(c,1)   and h=hhv(h,9);
drawicon(b,K,2),COLORGREEN;
金叉:if(M<20 AND cross(K,M),40,0),colorred;
回生:if(BARSLAST(金叉)<=9 AND BARSLAST(金叉)>2 AND cross(M,K) AND M<30,60,0),coloryellow;

回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2009-12-10 20:47 | 显示全部楼层
原帖由 子路 于 2009-12-7 13:12 发表
这是雨后春笋老师给的公式
副图公式:老张建仓

VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=EMA(CLOSE,5);
VAR10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
A:IF(VAR9>REF(VAR9,1),VAR9,0),COLORBLUE,LINETHICK0;
B:IF(VAR9>REF(VAR9,1),VAR9,0),COLOR1010FF,LINETHICK0;
STICKLINE(VAR8>REF(VAR8,1),0,VAR8,4,1),COLOR10FFFF;
进:IF(VAR8>REF(VAR8,1),VAR8*8,0),COLOR10FFFF,LINETHICK0;
STICKLINE(VAR8<REF(VAR8,1),0,VAR8,4,1)COLORFFF810;洗:IF(VAR8<REF(VAR8,1),VAR8*10,0),COLORFFF810,LINETHICK0;
持:(LOW*5),COLORFF10FF,LINETHICK0;
差:VAR10,COLORFF7676;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
STICKLINE(XL3,0,VAR8*3,4,0),COLOR006EFF;
DRAWTEXT(XL3,VAR8*2,'买'),COLORRED;
↑买:DRAWICON(XL3,0,4),COLORRED;
R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(R,3,1),COLORRED;
M:SMA(K,3,1),COLORYELLOW;
PARTLINE(K,K<M),COLORCYAN;
A:=K>=REF(K,1) AND C<=REF(C,1)  AND L=LLV(L,9) ;
DRAWICON(A,K,1),COLORRED;
B:=K<=REF(K,1) AND C>=REF(C,1)   AND H=HHV(H,9);
DRAWICON(B,K,2),COLORGREEN;
金叉:IF(M<20 AND CROSS(K,M),40,0),COLORRED;
回生:IF(BARSLAST(金叉)<=9 AND BARSLAST(金叉)>2 AND CROSS(M,K) AND M<30,60,0);

=================================================

第14行改成:STICKLINE(VAR8<REF(VAR8,1),0,VAR8,4,1),COLORFFF810;
就可以了,呵呵
回复 支持 反对

使用道具 举报

新浪微博达人勋

八级海风会员

发表于 2009-12-10 21:03 | 显示全部楼层
原帖由 wzwxy 于 2009-12-10 19:29 发表
我从老张那里拷贝的也是不可以。:(

Var2:=REF(LOW,1);
Var3:=SMA(ABS(LOW-Var2),13,1)/SMA(MAX(LOW-Var2,0),13,1)*100;
Var4:=EMA(IF(CLOSE*1.2,Var3*13,Var3/13),13);
Var5:=LLV(LOW,34);
Var6:=HHV(Var4,3 ...



上面的是飞狐软件的源码,大智慧和通达信不能用,我改了一下
但显示不全,只显示 买
副图(无未来函数)
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:(EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7)/5;
VAR9:=(EMA(CLOSE,5))*3;
VAR10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
STICKLINE(VAR9>REF(VAR9,1),0,VAR9*0.08,4,1),COLOR10E410;
减仓:IF(VAR9>REF(VAR9,1),VAR9,0),COLOR10E410,,NODRAW;
STICKLINE(VAR9<REF(VAR9,1),0,VAR9*0.08,4,1),COLOR1010FF;
增仓:IF(VAR9<REF(VAR9,1),VAR9,0),COLOR1010FF,,NODRAW;
STICKLINE(VAR8>REF(VAR8,1),0,VAR8,4,1),COLOR10FFFF;
主力进场:IF(VAR8>REF(VAR8,1),VAR8*8,0),COLOR10FFFF,,NODRAW;
STICKLINE(VAR8<REF(VAR8,1),0,VAR8,4,1),COLORFFF810;

洗缓:IF(VAR8<REF(VAR8,1),VAR8*10,0),COLORFFF810,NODRAW;
主力持仓:(LOW*10),COLORFF10FF,NODRAW;
增减力度:VAR10,COLORFF7676;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
STICKLINE(XL3,0,VAR8*3,3,0),COLOR006EFF;
DRAWTEXT(XL3,VAR8*2,'买'),COLOR006EFF;
↑买:DRAWICON(XL3,-0.2,9),COLORRED;

[ 本帖最后由 wzwxy 于 2009-12-11 08:25 编辑 ]
老张建仓(副图).JPG

评分

参与人数 1等级分 +50 现金 +500 收起 理由
wzwxy + 50 + 500 我很赞同

查看全部评分

╭⌒╮HAPPY━┅~ ¤关注;分析;挖掘;捕捉。首次介入:封板;必涨。二次介入:必涨;异量竭;龙回头。三次介入:首战。四次介入:再战。
╱◥█◣ ╱◥█◣
︱田︱田︱︱田︱田︱
╬╬╬╬╬╬╬╬╬╬╬╬╬╬
回复 支持 反对

使用道具 举报

新浪微博达人勋

二级海风会员

发表于 2009-12-10 22:29 | 显示全部楼层
谢谢大家的无私奉献,建议别光贴公式最好加上应用心得或公式使用说明。
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2009-12-11 07:57 | 显示全部楼层
公式是参考,决策在人脑。有些超准的公式是有未来的,慎用之。
回复 支持 反对

使用道具 举报

新浪微博达人勋

超级版主

发表于 2009-12-11 08:28 | 显示全部楼层
原帖由 xh59 于 2009-12-10 22:29 发表
谢谢大家的无私奉献,建议别光贴公式最好加上应用心得或公式使用说明。

最好的心得体会来自于长期跟踪,就象子路那样在这里开个帖子,选取其中一个公式,每日坚持选股,必有收获。

看看立桩量、并蒂莲的帖子中有多少翻番的股票就会明白。

回复 支持 反对

使用道具 举报

新浪微博达人勋

超级版主

发表于 2009-12-11 10:21 | 显示全部楼层
检测公式中有无含未来函数的小工具。
未来.GIF

检测未来函数.rar

347.66 KB, 下载次数: 213


回复 支持 反对

使用道具 举报

新浪微博达人勋

超级版主

发表于 2009-12-11 10:42 | 显示全部楼层
原帖由 新节奏 于 2009-12-7 20:21 发表
无法阻挡公式(主图叠加):
5:MA(C,5),COLORYELLOW;
10:MA(C,10),COLORMAGENTA;
20:MA(C,20),COLORGREEN;
30:MA(C,30),COLORCCCCCC;
60:MA(C,60),COLORFF6060;
{120:MA(C,120),COLOR0082FF;}
{年 ...


这个也有未来函数。
1.JPG

回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2009-12-11 14:37 | 显示全部楼层
曾经龙骨的MACD四彩线挺直观的
但放在TDX里显示这个,
当前公式 : MACD四 (指标画线公式)  
错误句 : INPUT:LONG(26),SHORT(12),M(9)
详细信息 : 您在括号前写的不是函数、公式等,
且缺少必要的运算符!
错误起始位置 : 0 ; 长度: 0
请子路兄看看是哪里出了问题,谢谢。。。
input:LONG(26),SHORT(12),M(9);
DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG),COLORRED,linethick0;
DEA  : EMA(DIFF,M),COLORMAGENTA,linethick0;
MACD : 2*(DIFF-DEA) ,linethick0;
A:=HHV(DIFF,300);
A*1.3,colorgreen,linethick0;
B:=MACD-REF(MACD,1);
mxa:=max(HHVALL(diff),HHVALL(dea),HHVALL(macd));
mna:=min(LLVALL(diff),LLVALL(dea),LLVALL(macd));
a2:=(mxa+mna)/2;
a3:=mxa-mna;  
mxb:=HHVALL(H);
mnb:=LLVALL(L);
b2:=(mxb+mnb)/2;
b3:=mxb-mnb;
diffa:=(diff-a2)*(b3/a3)+b2;
deaa:=(dea-a2)*(b3/a3)+b2;
macda:=(macd-a2)*(b3/a3)+b2;
b4:=-a2*(b3/a3)+b2;
PARTLINE(DIFFA,DIFF<REF(DIFF ,1), RGB(0,255,0),1,rgb(255,0,0)), linethick1;
PARTLINE(DEAA,DEA<REF(DEA,1),RGB(51,204,204),1,RGB(255,0,255)),linethick1;
STICKLINE(MACD>0 AND B>0,b4,MACDA,1,0),COLORRED;
STICKLINE(MACD>0 AND B<0,b4,MACDA,1,0),COLORGREEN;
STICKLINE(MACD<0 AND B>0,b4,MACDA,1,0),COLORMAGENTA;
STICKLINE(MACD<0 AND B<0,b4,MACDA,1,0),COLORBLUE;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,b4,b4+b3/20,6,0),COLORYELLOW;
DRAWTEXT(低位金叉,b4+b3/20,' 低位金叉'),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,b4,b4-b3/40,2,0),ColorFF00FF;
DRAWICON(二次金叉,deaa*0.995,1);
DRAWTEXT(二次金叉,b4-b3/40,' 二次金叉'),ColorFF00FF,align1;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,b4,b4-b3/40,2,0),Color00FF00;
DRAWLINE(A1=0,DEAA,底背离,DEAA,0),COLORRED,linethick2;
DRAWTEXT(底背离,b4-b3/40,' 底背离'),Color00FF00;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEAA,顶背离,DEAA,0),COLORGREEN,linethick2;

{K线图}
stickline(ISEQUAL AND C>=REF(C,1),C,C,7,1),COLORRED;
stickline(ISEQUAL AND C>=REF(C,1),H,L,0,0),COLORRED;
stickline(ISEQUAL AND C<REF(C,1),C,C,7,1),COLORFFFF00;
stickline(ISEQUAL AND C<REF(C,1),H,L,0,0),COLORFFFF00;
stickline(ISUP ,H,L,0,0),COLORRED;
stickline(ISUP ,C,O,7,1),COLORRED;
stickline(ISDOWN ,H,L,0,0),COLORFFFF00;
stickline(ISDOWN ,O,C,7,0),COLORFFFF00;

[ 本帖最后由 子路 于 2009-12-19 22:46 编辑 ]
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2009-12-12 11:13 | 显示全部楼层
老鼠仓公式大智慧不能用,有未定义字符???
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册会员 新浪微博登陆

本版积分规则

QQ|小黑屋|手机版|海风股票论坛 ( 闽ICP备05030991号-1 )|网站地图

GMT+8, 2017-10-24 02:59

 
快速回复 返回顶部 返回列表