请选择 进入手机版 | 继续访问电脑版
查看: 16115|回复: 14

KDJ共振+周线KDJ公式(tdx)

[复制链接]

新浪微博达人勋

五级海风会员

发表于 2008-7-31 22:20 | 显示全部楼层 |阅读模式

马上注册海风会员,享受更多便捷服务!

您需要 登录 才可以下载或查看,没有帐号?注册会员 新浪微博登陆

x
ZKDJ
{周线KDJ公式}
VAR1:=WEEKDAY>REF(WEEKDAY,1);
VAR2:=WEEKDAY<REF(WEEKDAY,1);
上周收盘价:=REF(C,SUMBARS(VAR2,1));
上周开盘价:=REF(O,SUMBARS(VAR2,1));
上周交易天数:=SUMBARS(VAR2,2)-SUMBARS(VAR2,1);
上周最高价:=REF(H,SUMBARS(VAR2,1));
上周最低价:=REF(L,SUMBARS(VAR2,1));
ZRSV:=(CLOSE-MIN(LLV(LOW,SUMBARS(VAR2,1)),LLV(上周最低价,SUMBARS(VAR2,5))))
/(MAX(HHV(HIGH,SUMBARS(VAR2,1)),HHV(上周最高价,SUMBARS(VAR2,5)))-
MIN(LLV(LOW,SUMBARS(VAR2,1)),LLV(上周最低价,SUMBARS(VAR2,5))))*100;
ZK:SMA(ZRSV,SUMBARS(VAR2,3)-SUMBARS(VAR2,1),1),COLORWHITE;
ZD:SMA(ZK,SUMBARS(VAR2,3)-SUMBARS(VAR2,1),1),COLORYELLOW;
ZJ:3*ZK-2*ZD,COLORMAGENTA,LINETHICK1;


KDJ共振
{KDJ共振+周KDJ}
K13:"KDJ.K"(13,3,3),COLORFFFFFF;
D13:"KDJ.D"(13,3,3),COLORFFFFFF,LINETHICK1;
K21:="KDJ.K"(21,3,3),COLOR0000FF;
D21:="KDJ.D"(21,3,3),COLOR0000FF,LINETHICK2;
K34:"KDJ.K"(34,3,3),COLORFF8800;
D34:"KDJ.D"(34,3,3),COLORFF8800,LINETHICK1;
K55:="KDJ.K"(55,3,3),COLOR00FF00;
D55:="KDJ.D"(55,3,3),COLOR008000;
DIBU:= K13<20 AND D13<20 AND K21<20 AND D21<20 AND K34<20 AND D34<20 AND D55<20;
STICKLINE(DIBU=1,-2,5,1,0),COLORRED;
TOBU:= K34>80 AND K21>80 ;
STICKLINE(TOBU=1,100,95,1,0)  ,COLORGREEN;
DD:=-10;
ZK:"ZKDJ.ZK",COLORRED;
ZD:"ZKDJ.ZD",COLORRED;
ZJ:"ZKDJ.ZJ",COLORRED;.

[ 本帖最后由 墨香 于 2012-1-5 09:48 编辑 ]
黄金广告位招租
回复

使用道具 举报

新浪微博达人勋

五级海风会员

 楼主| 发表于 2008-7-31 22:22 | 显示全部楼层
积极思考造成积极人生,消极思考造成消极人生;莫找借口失败,只找理由成功,不为失败找理由,要为成功找方法.
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2008-7-31 22:23 | 显示全部楼层
谢谢楼主提供
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2008-7-31 22:32 | 显示全部楼层
请教楼主,这个怎么处理
当前公式 : KDJ共振+周KDJ (指标画线公式)  
错误句 :
ZK:"ZKDJ.ZK",COLORRED
详细信息 : 某个操作数没有相应的操作符匹配!
错误起始位置 : 482 ; 长度: 9
回复 支持 反对

使用道具 举报

新浪微博达人勋

八级海风会员

发表于 2008-7-31 22:37 | 显示全部楼层
学习,谢谢提供源码。
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2008-8-5 14:44 | 显示全部楼层
谢谢提供。:victory: :victory:
回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2008-8-7 20:02 | 显示全部楼层

回复 4楼 的帖子

ZK:"ZKDJ.ZK",COLORRED
上面这句话里边的“ZKDJ”是第一个指标公式的名称,也就是楼主“周线KDJ公式”的名称,如果你改名了,那么把ZKDJ改成改过后的名字就可以了。
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

发表于 2008-8-7 23:23 | 显示全部楼层
图出来了,但不懂得看
回复 支持 反对

使用道具 举报

新浪微博达人勋

五级海风会员

发表于 2008-8-22 15:38 | 显示全部楼层

非常感谢可可

在研究这个周线公式,不知用它如何选股?
回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2008-8-22 16:09 | 显示全部楼层

我来补个图片

:) 我来补个图片,看着很好...谢谢LZ:) :) :)
捕获_2kdd.jpg
捕获kdj.jpg
未来的世界是,方向比努力重要,能力比知识重要,健康比成绩重要,生活比文凭重要,情商比智商重要!
回复 支持 反对

使用道具 举报

新浪微博达人勋

三级海风会员

发表于 2008-8-24 10:28 | 显示全部楼层
谢谢分享,看起来很不错的样子啊!
实战检验:victory:
回复 支持 反对

使用道具 举报

新浪微博达人勋

初级海风会员

发表于 2012-5-13 15:17 | 显示全部楼层
谢谢!楼主辛苦了。
回复 支持 反对

使用道具 举报

新浪微博达人勋

初级海风会员

发表于 2012-5-13 15:39 | 显示全部楼层
非常感谢可可
回复 支持 反对

使用道具 举报

新浪微博达人勋

四级海风会员

发表于 2015-8-16 16:36 来自手机 | 显示全部楼层
大智慧可以用吗?
回复 支持 反对

使用道具 举报

新浪微博达人勋

七级海风会员

发表于 2017-1-15 21:49 | 显示全部楼层
错误句 : K13:&QUOT
详细信息 : 未知字符串 &QUOT
错误起始位置 : 4 ; 长度: 5
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册会员 新浪微博登陆

本版积分规则

QQ|小黑屋|手机版|海风股票论坛 ( 闽ICP备05030991号-1 )|网站地图

GMT+8, 2017-10-21 12:54

 
快速回复 返回顶部 返回列表